Flag to enable "Do not verify server certificate in HTTPS syncing" for SeaDrive


For my server configuration, I have to enable “Do not verify server certificate in HTTPS syncing” on Windows to get SeaDrive working. On linux, I have to do the same thing but unfortunately I can’t open the SeaDrive settings dialog. I tried to set the seadrive.conf as following:

size_limit = 10GB
clean_cache_interval = 10

The size_limit should be probably the “Cache size limit” and “clean_cache_interval” the “Cache clean interval” on Windows. What is the key for “Do not verify server certificate in HTTPS syncing” in Linux settings?

It would be a better fix to use a valid certificate as with that option it is trivial for someone else to play mitm (man in the middle).

I know. But the admin at my place never installs a proper certificate for that. Now I have to skip the certificate because SeaDrive always complains “SSL Error”.

Is there anyone can help with this? Looking in the code base of seadrive-gui does not tell anything.

Perhaps you’re not looking for solutions any more. I’m not sure that I have one either. I’ll tell you what I did.

In my case I’m running arch linux and the package seafile-client is the gui application. The seafile server is on a different machine that is running debian. I also have the seadrive command line client installed on a second debian server.

The GUI desktop client worked after I set “Do not verfiy …” in the advanced setup.

I could not get the seadrive client to work. Then I discovered that the config is saved to a SQLite db file. I used sqlitebrowser to take a look at the working db config file for the GUI client and found the row that had the “Do not verify …” config setting. Looking at the db config for seadrive on the second debian server I could see that this row was not present. I copied the server db config over to my desktop and edited it to include the “Do not verify …” setting using sqlitebrowser. Then I copied it back to my server and seadrive worked. Even though seadrive has a command to set this value, that command wasn’t saving that setting and so I had to do it manually.

Maybe you can use this method to get your client working, assuming your networking is otherwise operational.
Good luck

1 Like