Folders with white spaces keep coming back by windows client


Seafile professional server.

On Macs we created some folders with spaces in the end of the folder name.
That was a mistake and was corrected at some stage - the spaces in the end were deleted.
Now they also synced to the Windows clients.

But somehow now the renamed folder is there but also the folder with the space in the end keeps coming back.

Interestingly it’s a windows client 7.0.9 that keeps bringing back these with spaces in the end - although they can’t see them.

Now we have some 20 folders that keep coming back.
What is the right thing to do to clean this mess up?

I tried deleting on Webinterface and on MacOS client, but that didnt help.

Any help would be appreciated.

Thanks, Chris

Did you run the garbage collector for the repo in question?
@Jonathan: Maybe something for 7.0.10?!

Hi, no I did not run that yet (On this server I am just a user, not the admin), but I will ask to run it.

I am not sure of this will help though.

What log should I look into that might give a clue?

Garbage cleaner purges (old versions of) files from the system after they have been cleaned from trash. I suppose you did that:

Hence, this is the procedure that should help you get rid of these “undead” folders: When the folders pop back up,
1.) Delete them from webinterface
2.) Clean the trash
3.) Have client sync the library
That should be it.

If this does not work, also run the garbage cleaner.

The process presumes that the folders “resurrect” somehow on the server.

If you think the Windows client digs them out somehow, I would proceed as follows:

  • Move the “good” (sub)folders into a new folder
  • End the sync with the old folder
  • Sync with the new folder
  • Delete the old folder

Thanks rdb

I will give this a try.

Hi rdb

This does not make any difference.
The same windows client keeps putting back the folder and files within.

This is still happening.

I am not sure what I can do.

@Jonathan May I politely ask if you have any idea?

You can try unsyncing the library on the 7.0.9 client that brings back the folders. The folder information is left over in the index file. I think this is a known bug reported before but didn’t get fixed. We’ll look into it.

Thanks for getting back to me Jonathan.

We will do the unsyncing and let you know if it fixed it.

Looking at this again there is one similarity:
All the libraries where this happens on our server are shared folders within a library.

Maybe that helps?