Fresh install of Seafile (Pro) Docker for Windows won't start properly

docker
windows

#1

I can’t get Seafile Community / Pro running in Docker on Windows 10 to start properly. Docker has default settings, except for I’ve assigned a shared drive D:\ to store the seafile data on.

The command I use is:

docker run -d --name seafilepro -e SEAFILE_SERVER_HOSTNAME=myseafile.server -e SEAFILE_ADMIN_EMAIL=an@email.com -e SEAFILE_ADMIN_PASSWORD=mHGZpHq3Gyj8dMfU7skks5e3hNSjySTqTwckgVwkL3rrVv85eqtJsjfpAbcTp6xD -p 8000:8000 -p 8080:8080 -p 8082:8082 -p 9000:9000 -v D:/seafilepro:/shared docker.seadrive.org/seafileltd/seafile-pro:latest

What usually happens is that Seafile boots up, but I believe it crashes during boot.
Some data gets written to the data drive, like the folders db, logs, and seafile.

When I point the browser to the myseafile.server:8000 (or localhost) chrome returns one of the following responses:

ERR_EMPTY_RESPONSE
ERR_CONNECTION_REFUSED

I’ve tried community edition and pro, both acts like the same way. I actually managed to get one server up and running one time with the same setup, but after I had to reboot docker it wouldn’t start again. But both before and after that time it failed many times. Between each time I tried I removed the docker container and installed fresh each time (while deleting the data folder).

Any help would be greatly appreciated.