FSCK showing clean, GC showing damaged


#1

So far been running with seafile for about a year now without issues, always had clean checks until this one, confused by the results, seems another user had a similar issue but actually found bad files, this error is pretty generic, not sure what to do about this.

FSCK comes up clean but GC says this, any idea’s?

[01/12/18 22:05:35] gc-core.c(653): === Repos deleted by users ===
[01/12/18 22:05:35] gc-core.c(677): Start to GC deleted repo 820439bf-81d0-4da8-bf67-4ea35afc84bf.
[01/12/18 22:05:35] gc-core.c(623): Deleting commits for repo 820439bf-81d0-4da8-bf67-4ea35afc84bf.
[01/12/18 22:05:35] gc-core.c(627): Deleting fs objects for repo 820439bf-81d0-4da8-bf67-4ea35afc84bf.
[01/12/18 22:05:35] gc-core.c(631): Deleting blocks for repo 820439bf-81d0-4da8-bf67-4ea35afc84bf.
[01/12/18 22:05:35] gc-core.c(854): === GC is finished ===
[01/12/18 22:05:35] gc-core.c(858): The following repos are damaged. You can run seaf-fsck to fix them.
[01/12/18 22:05:35] gc-core.c(861): 54ae2e2e-301b-4d2f-a344-fb537596ee0f
seafserv-gc run done

#2

Took the dirty method, created a new lib, copied all of the data into it, deleted the old one, no more errors, all consistency checks passed on database, from what i can tell the library hasn’t changed in the past 3 months, i ran these commands before my last upgrade, very odd…

Is there any sort of verbose mode to the GC? id love to see why it thought it was broken.


#3

I would love to see a feature to replace/migrate a Libray via admin interface/cli in case that its corrupted. This feature should then also restore the share settings/links.

@daniel.pan can this be added to the roadmap?


#4

@daniel.pan Do you have any idea what might cause this?


#5

I have exactly the same for one library (GC says corrupted, seaf-fsck does not find anything). But as the library is working fine, I just ignored it.


#6

#7

Thanks for the link, so the reason seems to be corruption in the history data. Not a problem for me at the moment, so I savely can ignore the warning.


#8

Thank you for this information!