Getting error when manually running virus scan

I installed a clean seafile server pro and clamav, added the conf to seafile.conf as described in Virus Scan.

Now when I do

# cd seafile-server-latest
# ./pro/pro.py virus_scan

It’s giving me

[01/24/2018 11:12:45] [WARNING] Failed to read seafile config, disable virus scan.
[01/24/2018 11:12:45] [INFO] Virus scan is disabled.

Any idea what’s wrong?

What AV you have configured? Also you could try chmodding the seafile conf location to 777

I’ve configured ClamAV. Seafile conf dir is set to 700 as by default. I use the seafile user to execute ./pro/pro.py virus_scan so there shouldn’t be a permission problem.

Hello,

I have the same error, Server Professional Edition v.6.2.8, CentOSv7.
ClamAV is installed.

seafile.conf:
[virus_scan]
scan_command = /usr/bin/clamscan
virus_code = 1
nonvirus_code = 0
#scan_size_limit =
scan_skip_ext = .bmp, .gif, .ico, .png, .jpg, .mp3, .mp4, .wav, .avi, .rmvb, .mkv
threads = 4

sudo -u seafile ./pro/pro.py virus_scan
[02/02/2018 16:24:02] [WARNING] Failed to read seafile config, disable virus scan.
[02/02/2018 16:24:02] [INFO] Virus scan is disabled.

Can you help with the advice?

Where is the config file placed and does it have correct permissions?

It seems that everything is ok with permissions.

# ls -la /opt/seafile/conf
total 36
drwx------.  2 seafile seafile 4096 Feb  2 17:47 .
drwxr-xr-x. 13 seafile seafile 4096 Feb  2 00:26 ..
-rw-r--r--.  1 seafile seafile  306 Feb  2 13:40 ccnet.conf
-rw-r--r--.  1 seafile seafile   73 Jan 31 18:16 seafdav.conf
-rw-r--r--.  1 seafile seafile 1080 Feb  1 18:11 seafevents.conf
-rw-r--r--.  1 seafile seafile 1154 Feb  2 16:23 seafile.conf
-rw-r--r--.  1 seafile seafile 4232 Feb  2 17:47 seahub_settings.py
-rw-r--r--.  1 seafile seafile 3689 Feb  2 17:47 seahub_settings.pyc

I also ran into this Problem.

Does anyone has a solution or idea?

Thanks
Siegfried