Having trouble upgrading Docker

Hi there,

I’m trying to upgrade my Docker installation of Seafile server from 6.1.1 to 6.2.2. I followed these instructions, but the upgrade fails stating that the port is already in use:

chris@fr /var/seafile $ sudo ./launcher rebuild
[2017-11-08 11:01:18] Ensuring launcher is up to date
Fetching origin
[2017-11-08 11:01:18] Launcher is up-to-date
[2017-11-08 11:01:19] Stopping old container
+ docker stop -t 10 seafile
seafile
docker: Error response from daemon: driver failed programming external connectivity on endpoint seafile-bootstrap (f2fd21633fab53b8b0d1330716b4c96428fe48600bcb3b9876ce5d1a936c9b2c): Bind for 0.0.0.0:22777 failed: port is already allocated.
ERRO[0001] error waiting for container: context canceled

Does anyone have any idea how to fix this/

Thanks for reading!

Chris

No idea why that happened. Try restart docker daemon (“service docker restart”). Or reboot your system.

I’d already tried rebooting the system after a couple of failed attempts. I just tried restarting the docker daemon but I still get the same error :frowning:

My experience with docker is extremely limited, but I thought I might be able to stop the container, remove it, then recreate it from the latest 6.2.2 image. But every time I try docker stop seafile the container automatically starts up again.

In case it’s of any significance, here’s the contents of my /var/seafile/bootstrap/bootstrap.conf file:

# If you edit this file, remember to run ./launcher rebuild
[server]
server.hostname = seafile.example.com
admin.email = chris@example.com
admin.password = xxxxxxxx

# Comment out this line and uncomment the two lines below to use letsencrypt SSL certificate
server.port_mappings = 22777:80
# server.letsencrypt = true
# server.port_mappings = 80:80,443:443