HELP - Server / nginx setup -- cannot get Web GUI going on Ubuntu 20.04

I am at my wit’s end, and any assistance would be appreciated. I am trying to set up the Seafile server on a Ubuntu 20.04 system running nginx on an internal LAN. The web server is definitely working, as I can see the “Welcome to nginx!” page on the server (at ‘localhost’ or the IP, 192.168.0.7) or from other computers on the LAN at that IP. But I cannot get the web-based Seafile server interface to load, despite trying all the steps in many various online tutorials.

Seafile-server was installed and initialized, and the scripts seafile.sh and seahub.sh have both been 'start’ed, without incident.

The firewall seems to be open on all the necessary ports:

>  sudo ufw status
> Status: active
> 
> To                         Action      From
> --                         ------      ----
> 22/tcp                     ALLOW       Anywhere                  
> 873/tcp                    ALLOW       Anywhere                  
> 8000                       ALLOW       Anywhere                  
> 8082                       ALLOW       Anywhere                  
> 22/tcp (v6)                ALLOW       Anywhere (v6)             
> 873/tcp (v6)               ALLOW       Anywhere (v6)             
> 8000 (v6)                  ALLOW       Anywhere (v6)             
> 8082 (v6)                  ALLOW       Anywhere (v6)  
> 80 (v6)                    ALLOW       Anywhere (v6)             
> 80/tcp (v6)                ALLOW       Anywhere (v6)             

And here is my seafile.conf file, located in /etc/nginx/conf.d/ :

server {
    listen 80;
    listen [::]:80;
    server_name  192.168.0.7;
    autoindex off;
    client_max_body_size 100M;
    access_log /var/log/nginx/seafile.com.access.log;
    error_log /var/log/nginx/seafile.com.error.log;

     location /seafile {
            proxy_pass         http://127.0.0.1:8000;
            proxy_set_header   Host $host;
            proxy_set_header   X-Real-IP $remote_addr;
            proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_set_header   X-Forwarded-Host $server_name;
            proxy_read_timeout  1200s;
            access_log      /var/log/nginx/seahub.access.log;
            error_log       /var/log/nginx/seahub.error.log;
        }

     location /seafhttp {
            rewrite ^/seafhttp(.*)$ $1 break;
            proxy_pass http://127.0.0.1:8082;
            proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_connect_timeout  36000s;
            proxy_read_timeout  36000s;
            proxy_send_timeout  36000s;
            send_timeout  36000s;
        }

    location /seafmedia {
            rewrite ^/seafmedia(.*)$ /media$1 break;
            root /srv/seafile/seahub;
        }
}

Again: if I go to the server’s site I just see the nginx default welcome banner. If I try to go to “192.168.0.7:8000” or “192.168.0.7:8082” I just get
Firefox can’t establish a connection to the server at 192.168.0.7:8000.

Any suggestions or recommendations would be most welcome!