How to enable Search in Seafile CE? (was: File History not Available in seahub (docker, 8.0.3))


i am using seafile docker 8.0.3 behind an additional nginx reverse proxy to bind also other docker containers to port 80/443

When i want to see a file history in seahub…

I get the following Errormessage in the Webbrowser:

when i looked at seahub.log i saw the following errormessage:

2021-02-16 10:45:18,178 [ERROR] django.request:228 log_response Internal Server Error: /repo/file_revisions/ae164057-8cc4-4c3c-82de-2858e7d0df7c/
Traceback (most recent call last):
File “/opt/seafile/seafile-server-8.0.3/seahub/thirdpart/django/core/handlers/”, line 34, in inner
response = get_response(request)
File “/opt/seafile/seafile-server-8.0.3/seahub/thirdpart/django/core/handlers/”, line 115, in _get_response
response = self.process_exception_by_middleware(e, request)
File “/opt/seafile/seafile-server-8.0.3/seahub/thirdpart/django/core/handlers/”, line 113, in _get_response
response = wrapped_callback(request, *callback_args, **callback_kwargs)
File “/opt/seafile/seafile-server-8.0.3/seahub/seahub/auth/”, line 27, in _wrapped_view
return view_func(request, *args, **kwargs)
File “/opt/seafile/seafile-server-8.0.3/seahub/seahub/views/”, line 779, in file_revisions
suffix_list = seafevents_api.get_file_history_suffix()
AttributeError: ‘NoneType’ object has no attribute ‘get_file_history_suffix’

I also tried to downgrade back to 7.1.5 - but that had no effect to this problem.

Can anyone confirm this bug or tell me what i have to change to avoid this problem?

Has anyone any ideas how this could happen in the docker version? I didn’t touch the container - and the reverse proxy in front of the container should also be no problem because i get the request in the container as i see in the logs.
Any idea anybody?

Hello together,

i investigated further. When i searched for “get_file_history_suffix” in this forum i found this thread, which told me to remove the file seafevents.conf from the conf folder.
I added this file because i wanted to enable search in my Seafile CE server - and i did like here described for the PRO version because i found no other place wher enabling the search functionality was explained.
After i removed the seafevents.conf file i was again able to see the history of my files. but i could not search anymore.
Can anyone explain how to enable search in CE without loosing the ability to see the file history? Is there somewhere a manual which i did not find until yet?

Content of my seafevents.conf file is:

external_es_server = true
es_host = elasticsearch
es_port = 9200
## must be “true” to enable search
enabled = true

## The interval the search index is updated. Can be s(seconds), m(minutes), h(hours), d(days)

## If true, indexes the contents of office/pdf files while updating search index
## Note: If you change this option from “false” to “true”, then you need to clear the search index and update the index again.

I was just dumb and didn’t understand that the Search in SeafileCE is only a search for filenames and not an indexed search over all documents. So Elasticsearch is not needed - seafevents.conf is not needed and when i am inside a library i can also search - i tried to search over all libraries which does not work. All my fault. Thanks Seafile Team for this great peace of software!