How to prevent client from going to internet when server is local

I have set up a home Seafile server on Ubuntu Server 16.04 and most everything works fine, except… Every time I try to interact with the server using the Windows client while on the same local server it seems to be going through the internet instead of directly communicating with the local ip of the server. The server is set up with ddclient to keep my personal domain pointed to it, and the client is using that domain to easily connect to the server. While it works, I believe it is going much slower than it should because it is going to the internet and back instead of going straight to the server and back within the local network (and also eating through the data cap from my ISP in the process). I don’t know how to accurately test this to see what is actually happening, I am just assuming I have something set wrong.

I am now setting up a new server that I want to migrate my seafile server to, and am now taking the opportunity to set this up better this time around. With that being said, how do I properly set up the server such that it will:
a) have the dynamic dns to easily connect to
b) skip going to the internet and back when on the same local internet as the server?

I know this may be more complicated than simply tweaking settings for the Seafile server or client, but I can’t seem to find the answer elsewhere.

Please help educate the noob that I am, that I may rise above this…

1 Like