If the phone does not have a SIM, then no folders are synchronized to the Seafile server

If the phone does not have a SIM, then no folders are synchronized to the Seafile server.
All files and libraries that are already on the server are visible and accessible on the mobile client.
How can this be corrected?
The phone has access to the Internet via Wi-Fi.
Version 2.2.1 for Android

Updated to 2.2.2
The problem persists.
Folders and files are not synchronized to the server, not even folders were created.

Ie, there is no answer to the question?
And it is true assertion: If the phone does not have a sim card, then synchronization will not take place.

You don’t need a SIM card in order to use the Seafile app. But, I am confused about what you are saying here. The Seafile app for the phone is not a sync client, but rather a file access client. So, I’m not certain what you are trying to do. The proper function of the app is to access the Seafile server and allow you access files on it. You can upload files from your phone or download them from the server. According to you original comment, it sounds as if you have access to those files, which is the proper behavior of the client.

Now, with that being said, you can turn on contacts and photo backup inside the app, Is that what you are trying to do? What Android version do you have on your phone, btw?

Thank you very much for your response to my problem.
I’ll tell you everything in order.

  1. First of all, as you correctly noted, I expect from the mobile client only to synchronize the camera album and backup contacts.
  2. I will not say that I’m a very big expert in Seafile, but nevertheless, I constantly use the server since version 4.0.2 and mobile client version 1.2.0
  3. All this time, there were sometimes minor problems that you on your part quickly solved :slight_smile: And I always came up with answers to my questions here on the forum :slight_smile:
  4. My family, and other relatives use our cloud without any problems. All devices based on android different versions. I myself use the Blackberry Z10, installing the application of their apk file :slight_smile:
  5. With the introduction of my new Sony Experia Z1 Compact phone, the first thing I did was install Seafile Client v.2.2.1. I use a Wi-Fi network. I do not plan to install a SIM card, because for the calls I use Blackberry, but here’s a camera, and using other services not available on the Blackberry, I like this smartphone very much. This is where I started with the behavior of the Seafile client.
    Just created a contact in the address book. I tried to make a backup copy of contacts. A folder was created on the server, and it was synchronized to my PC D: \ Seafile \ SONY \ Contacts Backup.
    But the file Contacts-2018-04-05.vcf itself was not transferred to the server. When I looked through the file manager on the SONY device, I found this file.
    The path to the file on the SD card /ANDROID/MEDIA/COM.SEAFILE.SEADROID2/MYMAIL@MYDOMEN.ORG(CLOUD.MYDOMEN.ORG)/MY CLOUD IN HOME / CONTACTS BACKUP / contacts-2018-04-05.vcf
    On the devices of the wife and child, they have exactly the same devices, the transfer of files from the camera and contacts is without any problems.
    I tried hard reset, full reset the phone to factory settings, updated the version to Seafile Client v.2.2.2.

On all smartphones, the version of Android 5.1.1

I will look into it. I have a tablet that does not have cell access and therefore no SIM card. However, it is a much newer version of Android, but I believe that it syncs my photos properly as I had tried it at one time. However, I store contacts via Google contacts rather than on the device itself.

It is possible to store the contacts on a SIM card, but since you aren’t using a SIM card then the contacts must be stored somewhere else. I will dig into the code of the Android app and see how it grabs those contacts, but I do not have a version as old as you have of the Android client. There may be a compatibility problem between Seafile 2.X.X and Android 5.1.1. I have a busy day, but will look into this asap.

Also, what version of the Server are you running?

One other thing I just thought about. The URL for your Seafile Server on the phone without the SIM. Does it point to an external address/domain or the internal one? Are you trying to sync internally with your domain or from a remote location?

Some routers have an issue with what’s called NAT reflection, and that could be a problem as well, which would explain why phones with cell access work but those that don’t, won’t.