Install Seafile-cli client on Raspberry Pi


So i tried to compile it again. build_seafile

It went through but i get this problem.

 seaf-cli start
/root/.ccnet not exists
Invalid config directory

I don’t know!

Forget to do this …

choose a folder where to store the seafile client settings e.g ~/seafile-client

mkdir ~/seafile-client # create the settings folder
seaf-cli init -d ~/seafile-client # initialise seafile client with this folder
seaf-cli start
So it’s working now. How can i get this as a deb package :smiley:


You can use Checkinstall for that:


Yeah, thanks.

I did this before, too. Just forgotten that i did it before, too :smiley: It’s sometimes just too much ;D
But thanks.

It went through. I got the packages. Compiled it on a pi 3 and installed it on a pi 2. I got a few hiccups on a pi 2. Sometimes it took about 1 min to get the pi 2 alive and the client stopped then. I couldn’t figured out why this happened.


Two thumbs up for doing this. These packages saved me hours of work. I installed them on raspbian jessie on a pi3. Works great! I wonder why the devs don’t provide these, not enough time in a day to get to everything I guess.

Thank you very much.


You are welcome. I would love to provide newer packages but got problems to compile every version above 6.0.0. :frowning:


I am using a fresh Raspbian9 on my RaspiB+ and followed your guide on Github and it installes it completely, but when i try to start seafile with seaf-cli init -d ~/seafile-client i get this Error:

ccnet-init: error while loading shared libraries: cannot open shared object file: No such file or directory
Failed to init ccnet

i tried to manually install libssl but its not in the upstream anymore.


That’s always the problem with new versions. Now I#m using WebDAV, then it’s much easier than compiling everytime new.


Yes and when my bike is broken i use the car instead. Thats a good solution to my bike-problem.


Hi @Ralosso,

unfortunately I’m not using ARM systems anymore for Seafile so I can’t reproduce your problem. Sorry…


ok seems the Bike is more than broken :wink:

Maybe bionade24 could explain how seafile works with webdav on a raspi or give a tutorial?


This Link today, Questions tomorrow:

Edit: If you are using nginx, you don’t have to enable fastcgi, you can make it like in the apache sample. Fastcgi only takes power of the server, it won’t help you.


Hi, guys
I have compiled seafile-client gui and seafile-cli for two versions of the Raspbian system Jessie and stretch, you can download at

# For stretch version, the jessie same too.
sudo dpkg -i libsearpc-3.0.0-1_armhf_rpi_stretch.deb
sudo dpkg -i ccnet_6.1.1-1_armhf_rpi_stretch.deb
sudo dpkg -i seafile_6.1.1-1_armhf_rpi_stretch.deb # seafile-cli, the command seafile client
sudo dpkg -i seafile-client_6.1.1-1_armhf_rpi_stretch.deb # seafile-client gui

For compile install way, you can visit stackexchange.

enjoy it~

Seaf-cli on Raspian Stretch

Thank you. I tried it but I haven’t enough time to search why an error happens


Thanks a lot ! You spared me a lot of effort building it myself ! :slight_smile:


This version is very old. You can easily install 6.18 from the Debian backports with sudo apt install seafile-gui and upgrade it with sudo apt upgrade. If you get an GPG error, install the debian-keyrings.

Edit: please remove the other package before with sudo apt purge seafile-client


Oh thanks ! I didn’t realize it was in the backports. :slight_smile: I struggled a bit to install it (even after purging the old one) but finally did it with aptitude, with its nice problem-solving mechanism.


I’ve tried to install seafile-cli from backports to prevent problems with self compiling (this time on an raspberry pi) but everytime i try to do seaf-cli init -d ~/seaf-cli i get an Failed to init ccnet error. Has anyone had the same problems with the backorts-client and knows how to solve it? Or where to search for the problem? AFAIK Logging for seafile-cli starts only after the init command - and so there is no logging done yet which could help me…


No I don’t have this Problem, but for sure @schlarbm can help you.


I don’t know, I’ve never used the command line client standalone before.
Are you sure there is no logging in ~/.ccnet?

There are some environment variables that you can set to enable more debugging output, maybe that helps.

Seaf-cli on Raspian Stretch

i tried it once again. Purged everything before.

pi@raspberrypikitchen:~ $ sudo apt-get -t stretch-backports install "seafile-cli"
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
The following additional packages will be installed:
  ccnet libccnet0 libjansson4 libsearpc1 python-seafile seafile-daemon
Die folgenden NEUEN Pakete werden installiert:
  ccnet libccnet0 libjansson4 libsearpc1 python-seafile seafile-cli seafile-daemon
0 aktualisiert, 7 neu installiert, 0 zu entfernen und 57 nicht aktualisiert.
Es müssen 343 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 895 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j


pi@raspberrypikitchen:~ $ export SEAFILE_DEBUG=all
pi@raspberrypikitchen:~ $ seaf-cli init -d ~/seafile-cli
Failed to init ccnet
pi@raspberrypikitchen:~ $ cd ~/.ccnet
-bash: cd: /home/pi/.ccnet: Datei oder Verzeichnis nicht gefunden

So - as far as i see there is no logging until ccnet is startet :confused: