Install Seafile-cli client on Raspberry Pi


#23

Yep, the other guy about you, DanSman is me. So, not many people have the problem or not many people need to compile the client. :wink:


#24

Hello,

any news here?

I run in a new problem. Actually i installed my whole pi again. And i get some problems with ccnet.

seaf-cli init -d ~/seafile-client
ccnet-init: error while loading shared libraries: libevent-2.0.so.5: cannot open shared object file: No such file or directory
Failed to init ccnet

So when i start the client i get this problem

seaf-cli start
/home/pi/.ccnet not exists
Invalid config directory

Sure i can’t finish the install properly.

I need a little bit help.


#26

So i tried to compile it again. build_seafile

It went through but i get this problem.

 seaf-cli start
/root/.ccnet not exists
Invalid config directory

I don’t know!

EDIT:
Forget to do this …

choose a folder where to store the seafile client settings e.g ~/seafile-client

mkdir ~/seafile-client # create the settings folder
seaf-cli init -d ~/seafile-client # initialise seafile client with this folder
seaf-cli start
So it’s working now. How can i get this as a deb package :smiley:


#27

You can use Checkinstall for that: https://wiki.debian.org/CheckInstall


#28

Yeah, thanks.

I did this before, too. Just forgotten that i did it before, too :smiley: It’s sometimes just too much ;D
But thanks.

It went through. I got the packages. Compiled it on a pi 3 and installed it on a pi 2. I got a few hiccups on a pi 2. Sometimes it took about 1 min to get the pi 2 alive and the client stopped then. I couldn’t figured out why this happened.


#29

Two thumbs up for doing this. These packages saved me hours of work. I installed them on raspbian jessie on a pi3. Works great! I wonder why the devs don’t provide these, not enough time in a day to get to everything I guess.

Thank you very much.


#30

You are welcome. I would love to provide newer packages but got problems to compile every version above 6.0.0. :frowning:


#31

Hello,
I am using a fresh Raspbian9 on my RaspiB+ and followed your guide on Github and it installes it completely, but when i try to start seafile with seaf-cli init -d ~/seafile-client i get this Error:

ccnet-init: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory
Failed to init ccnet

i tried to manually install libssl but its not in the upstream anymore.


#32

That’s always the problem with new versions. Now I#m using WebDAV, then it’s much easier than compiling everytime new.


#33

Yes and when my bike is broken i use the car instead. Thats a good solution to my bike-problem.


#34

Hi @Ralosso,

unfortunately I’m not using ARM systems anymore for Seafile so I can’t reproduce your problem. Sorry…


#35

ok seems the Bike is more than broken :wink:

Maybe bionade24 could explain how seafile works with webdav on a raspi or give a tutorial?


#36

This Link today, Questions tomorrow: https://manual.seafile.com/extension/webdav.html

Edit: If you are using nginx, you don’t have to enable fastcgi, you can make it like in the apache sample. Fastcgi only takes power of the server, it won’t help you.


#37

Hi, guys
I have compiled seafile-client gui and seafile-cli for two versions of the Raspbian system Jessie and stretch, you can download at http://t.cn/RmtFlMZ.

# For stretch version, the jessie same too.
sudo dpkg -i libsearpc-3.0.0-1_armhf_rpi_stretch.deb
sudo dpkg -i ccnet_6.1.1-1_armhf_rpi_stretch.deb
sudo dpkg -i seafile_6.1.1-1_armhf_rpi_stretch.deb # seafile-cli, the command seafile client
sudo dpkg -i seafile-client_6.1.1-1_armhf_rpi_stretch.deb # seafile-client gui

For compile install way, you can visit stackexchange.

enjoy it~


#38

Thank you. I tried it but I haven’t enough time to search why an error happens