Internal server error on fresh install, ubuntu 20, seafile 9.x


I am trying to test this service on fresh vms with no success. At first I did the manual install and all was going well until I was unable to run script. Run into some missing dependencies which I was not able to solve despite reinstalling missing packages.

Decided to give the installation script a try. Script run fine and I can see the service is running. When I visit the address we get “Internal Server Error”. At first I thought it was an nginx problem so tried to run it without reverse proxy and modified configuration files, no success. Than I found FAQ in the manual which says:

It is mostly likely some required Python packages of Seahub is not installed correctly.
You can check the detailed error messages in /var/log/nginx/seahub.error.log if you use Nginx.

I reverted the modified files and tried reading the logs. Problem is those logs are empty and the service appears to be running correctly. Rechecked all dependencies, no idea where do I go from there.

This was tried on fresh virtual machine on two different machines. Ubuntu 20.04.3 server image. Any ideas?

I know my first post doesn’t have much info but it is a clean install and I run into same issues on 2 different hosts. Surprised noone else has run into similar problems as of recently, since the problem should be easy to reproduce.

Either way, I wasn’t able to solve the issue. Will try to get a Debian install running this weekend and also try docker deployment.


I can’t reproduce your issue on an Ubuntu 20.04 VM. Seafile 9 (sqlite deployment) with the following dependencies (from manual):

# on Ubuntu 20.04 server

apt-get install -y python3 python3-setuptools python3-pip memcached libmemcached-dev pwgen sqlite3

pip3 install --timeout=3600 django==2.2.* future Pillow pylibmc captcha jinja2 psd-tools django-pylibmc django-simple-captcha pycryptodome==3.12.0 cffi==1.14.0

Rather than nginx logs, have you checked Seafile ones (logs folder on the same level as the server folder)?

Not necessary. Ubuntu is the preferred platform.

Please follow these instructions precisely: Installation with MySQL - Seafile Admin Manual (I don’t use the scripts, I think they are poorly maintained.)

If you follow the tutorial for the manual installation, you’ll get a working system. I did so myself a few days ago.

If you keep running into trouble, post your config files here (after removing the passwords).