Internal Server Error


#1

Hi. I have 6.2.4 running on an Amazon EC2 instance and all was working fine. At some point I am guessing there was a python update or something similar and now I cannot connect to sahub. I keep getting “Internal Server Error”.

I tried a fresh install and same problem. Nothing in the error logs.

Here is a list of python packages installed. Any insight would be greatly appreciated.

gamin-python.x86_64 0.1.10-16.14.amzn1 @amzn-main
libxml2-python27.x86_64 2.9.1-6.3.49.amzn1 installed
newt-python27.x86_64 0.52.11-3.11.amzn1 installed
python27.x86_64 2.7.12-2.121.amzn1 installed
python27-PyYAML.x86_64 3.10-3.10.amzn1 installed
python27-babel.noarch 0.9.4-5.1.8.amzn1 installed
python27-backports.x86_64 1.0-3.14.amzn1 installed
python27-backports-ssl_match_hostname.noarch
python27-chardet.noarch 2.0.1-7.7.amzn1 installed
python27-colorama.noarch 0.2.5-1.7.amzn1 installed
python27-configobj.noarch 4.7.2-7.15.amzn1 installed
python27-crypto.x86_64 2.6.1-1.14.amzn1 installed
python27-daemon.noarch 1.5.2-1.5.amzn1 installed
python27-dateutil.noarch 2.1-1.3.amzn1 installed
python27-devel.x86_64 2.7.12-2.121.amzn1 installed
python27-ecdsa.noarch 0.11-3.3.amzn1 installed
python27-futures.noarch 3.0.3-1.3.amzn1 installed
python27-imaging.x86_64 1.1.6-19.9.amzn1 @amzn-main
python27-iniparse.noarch 0.3.1-2.1.9.amzn1 installed
python27-inotify.noarch 0.9.1-1.7.amzn1 @amzn-main
python27-jinja2.noarch 2.7.2-2.15.amzn1 installed
python27-jmespath.noarch 0.9.2-1.12.amzn1 installed
python27-jsonpatch.noarch 1.2-2.5.amzn1 installed
python27-jsonpointer.noarch 1.0-3.4.amzn1 installed
python27-kitchen.noarch 1.1.1-5.6.amzn1 installed
python27-ldap.x86_64 2.3.10-1.13.amzn1 @amzn-main
python27-libs.x86_64 2.7.12-2.121.amzn1 installed
python27-lockfile.noarch 0.8-3.5.amzn1 installed
python27-markupsafe.x86_64 0.11-4.6.amzn1 installed
python27-paramiko.noarch 1.15.1-1.5.amzn1 installed
python27-pip.noarch 9.0.1-1.24.amzn1 installed
python27-ply.noarch 3.4-3.12.amzn1 installed
python27-pyasn1.noarch 0.1.7-2.9.amzn1 installed
python27-pycurl.x86_64 7.19.0-17.12.amzn1 installed
python27-pygpgme.x86_64 0.3-9.12.amzn1 installed
python27-pyliblzma.x86_64 0.5.3-11.6.amzn1 installed
python27-pystache.noarch 0.5.3-2.8.amzn1 installed
python27-pyxattr.x86_64 0.5.0-1.6.amzn1 installed
python27-requests.noarch 1.2.3-5.10.amzn1 @amzn-main
python27-rsa.noarch 3.4.1-1.8.amzn1 installed
python27-setuptools.noarch 36.2.7-1.33.amzn1 installed
python27-simplejson.x86_64 3.6.5-1.12.amzn1 installed
python27-six.noarch 1.8.0-1.23.amzn1 installed
python27-urlgrabber.noarch 3.10-8.16.amzn1 installed
python27-urllib3.noarch 1.8.2-1.5.amzn1 installed
python27-virtualenv.noarch 15.1.0-1.14.amzn1 installed
rpm-python27.x86_64 4.11.3-21.75.amzn1 installed


#2

Did you try updating seafile? I had this issue after I tried updating to 6.2.5.


#3

Yes. It started with 6.2.3. I tried to updated to 6.2.4 and it did not fix the issue.


#4

Did you check the logfiles for any obvious entries?


#5

This might even be totally unrelated to python.
Did you check for basic errors? Are all services running, ports open? Webserver update? Config change?

Personal question aside:
What single project has enough cash to host seafile on AWS? This is very expensive. :scream:


#6

Yes, all services are running as far as I can tell. Ports are open. No config change, just updates to the OS. Just updated to 6.2.5 and same thing. Even setting up a new instance in a different folder has the same problem. Nothing in the log files. As for the AWS, not sure why you feel this is expensive but for our setup it is fairly cheap.

Thanks!


#7

How much do you pay and how what resources do you use? How much traffic?


#8

Its about $30/month. We run our www on there as well.


#9

This may not be much right now. But this price could go higher if your instance were to be attacked or you do more tasks that require load. AWS charges for things that don’t need charging because they can.
Have a look at the Hetzner Cloud for example. It can be done differently.
I really hope that there will be a product that takes on AWS/Azure/etc. all together to put a lever in front of this madness.


#10

Appreciate the input but this is all a moot point since seafile won’t run. Anyone have any brilliant ideas. Running 6.2.5 and still the same problems.

Thanks!


#11

Please post the output of netstat -tulpn and check the seafile ports (localhost) with nmap -p <port>.
I’d also recommend to purge all python stuff (do a snapshot before) and re-install them cleanly.


#12

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:8000 0.0.0.0:* LISTEN 5356/python2.7
tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN 2891/dovecot
tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN 2891/dovecot
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 2852/mysqld
tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 2891/dovecot
tcp 0 0 127.0.0.1:783 0.0.0.0:* LISTEN 32506/spamd.pid
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 2891/dovecot
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 2492/rpcbind
tcp 0 0 0.0.0.0:465 0.0.0.0:* LISTEN 3001/master
tcp 0 0 0.0.0.0:49233 0.0.0.0:* LISTEN 2513/rpc.statd
tcp 0 0 0.0.0.0:8082 0.0.0.0:* LISTEN 22941/seaf-server
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 2608/sshd
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 3001/master
tcp 0 0 :::993 :::* LISTEN 2891/dovecot
tcp 0 0 :::995 :::* LISTEN 2891/dovecot
tcp 0 0 :::110 :::* LISTEN 2891/dovecot
tcp 0 0 ::1:783 :::* LISTEN 32506/spamd.pid
tcp 0 0 :::143 :::* LISTEN 2891/dovecot
tcp 0 0 :::111 :::* LISTEN 2492/rpcbind
tcp 0 0 :::80 :::* LISTEN 2819/httpd
tcp 0 0 :::22 :::* LISTEN 2608/sshd
tcp 0 0 :::33463 :::* LISTEN 2513/rpc.statd
udp 0 0 0.0.0.0:5060 0.0.0.0:* 18049/asterisk
udp 0 0 0.0.0.0:971 0.0.0.0:* 2492/rpcbind
udp 0 0 127.0.0.1:1001 0.0.0.0:* 2513/rpc.statd
udp 0 0 0.0.0.0:48426 0.0.0.0:* 18049/asterisk
udp 0 0 0.0.0.0:48885 0.0.0.0:* 2513/rpc.statd
udp 0 0 0.0.0.0:68 0.0.0.0:* 2250/dhclient
udp 0 0 0.0.0.0:111 0.0.0.0:* 2492/rpcbind
udp 0 0 172.31.27.85:123 0.0.0.0:* 2618/ntpd
udp 0 0 127.0.0.1:123 0.0.0.0:* 2618/ntpd
udp 0 0 0.0.0.0:123 0.0.0.0:* 2618/ntpd
udp 0 0 fe80::dd:21ff:fe4c:9c0e:546 :::* 2366/dhclient
udp 0 0 :::971 :::* 2492/rpcbind
udp 0 0 :::44930 :::* 2513/rpc.statd
udp 0 0 :::32865 :::* 18049/asterisk
udp 0 0 :::111 :::* 2492/rpcbind