iOS app sync issue


I set up a Seafile server on Ubuntu and it is running fine with all desktop clients.

But I have an issue with Seafile iOS client: if I add a new file/folder through the app itself, everything syncs fine. But if I use a different app like Scanbot, Pages, … and then try to upload a file through the “share” functionality by selecting “Copy to SeafilePro” option, then the file is showing up in the Seafile app, but with status “Waiting for upload”. I waited for some time and theses files will not be uploaded…they remain in this state.

Because of this it is not possible to use Seafile seriously…I scan many files and need to upload them directly to Seafile from the scanner app.

Any ideas?

Kind regards,

We will look at the issue.

I can’t reproduce the issue by san a file, then choose “Share -> Open In -> Copy to Seafile Pro”.

Do you upload a folder? Do you have a screenshot?

Hi Daniel,

my server (Ubuntu 16.10, 16GB RAM, i7 3770 cpu) is running properly and pretty fast. I use 3 macOS desktop clients and synchronization between these 3 clients works properly.

I only have the issue on my iOS device (iPhone 7)…didn’t test other mobile devices yet.

I use some iOS 3rd party apps and tried to upload files to Seafile (like Pages, Scanbot). Then the uploaded file appear in Seafile client with “Waiting for upload” status. Network connection on my iOS device works fine…I also can open all files which are synced from desktop clients.

Like this:

Kind regards,

And no, I didn’t upload a folder.

I created the “Test 2” folder in the above screenshot from my iPhone and this worked fine.

hi. i have a similar problem, but only on one of my iphones.

non-working iphone: iphone 6s, ios 10.2.1. file upload or camera roll sync does not work via the seafile pro app. i can upload a photo via safari on this iphone and it shows up in the ios client and can be viewed. i’ve tried deleting and re-downloading the app, and resetting network settings. i haven’t tried a full wipe yet.

working phone - iphone 6s plus, ios 10.2.1. file upload and camera roll sync works.

seafile server is community version 6.0.7 running on freebsd 11

I’ve been experiencing a similar issue. In my case I can’t upload large files (I guess more than 50MB). Either the upload indicator gets stuck at zero until I cancel or it closes by itself after two or three seconds without moving.