iOS cache problem with pdf files

Hi, there is a problem with opening pdf files within iOS10 app.
You can open pdf correctly at first but all of a sudden only the first pdf file that has been opened would show up. that means all pdfs that are already in cache show up as the first one opened!

After clearing cache all is fine again. But the problem reoccurs on the same day.

is this a bug?

We will look into the issue.

Hello, we have the same issue in an Ipad with IOS 10.3. Seafile worked fine for some weeks, but after an update we do regulary have corruped (PDF) files on the device. PDFs do not open any longer. After deleting the local cache and a new download of the files everything is fine for some days.

Any ideas how to fix? Regards, Martin

AddOn: IOS 10.3.1, Seafile APP 2.5.9. Backgroud Data are allowed in the IOS Settings. Usually connected with LTE

Hi, I’ve the same issue and allready description in this post.

Best regards,…

@daniel.pan We have several customers with this problem too. Please have a look at it.
Issue got fixed.

Hi, for me version 2.6.0 does not fix the issue.
Let me explain my observations.
If i download a file for the first time (no cache) with iOS client for example pdf, all is fine . A second file ( for example pages docx) is ok too.
After I close the seafile client start seafile again and open one of these files directly from cache all is fine again.
But if I open the other file from cache the first one is showing up again. Thats frustrating.
Please fix this issue.

Hello, we have the same situation as Gregor mentioned.

The Offline cache is still not stable with 2.6. The second opening doesn’t work, etc.

Sometimes the “red check” gets grey, or no automatc download,…

Please fix it.

Thanks, Martin

Hello to all,

we still have trouble with the IOS 2.6.1 Client.

The Offline Sync still doesn’t work stable.

That sucks :frowning:

Maybe you can first offer a downgrade to a stable Version like 2.5.x from Spring 2017 ?

After a intensive Beta Test you can afterwards deploy a really stable Client 2.6.x

Regards, Martin