Ios camera upload stopped working [seafile 6.2.3]


#1

Hi everyone,
I’m using private seafile since version 4.x and everything worked so far.
Since I updated so some 5.x version the camera upload (ios) doesn’t work anymore. I cant tell the exact version, because i just noticed it stopped working. (since I upload my mobile photos only every few month)
I have a second server (for office use) running on version 5.1.1 where upload works - so the phone shouldn’t be the problem.

When I start the iphone app and open settings -> upload I see five images with status “waiting to upload”, but nothing happens.

Strange is, that i used the 5.1.1 office server configs to setup my private server. So the config was nearly identical in the beginning.
Also I did not change the private servers config between working state and now.
Seafile logs does not show any errors (or I don’t recognize them as errors) and I have no idea why the upload stopped working.

edit: forgot to mention I did all updates from 5.0 to 6.2 today - problem still occurs.

here are my configfiles:

ccnet.conf
[General]
USER_NAME = seafile
ID = (some-id)
NAME = seafile
SERVICE_URL = https://cloud.mydomain.de

[Network]
PORT = 10001

[Client]
PORT = 13418

[Database]
ENGINE = mysql
HOST = 127.0.0.1
PORT = 3306
USER = seafile
PASSWD = (secret)
DB = ccnet-db
CONNECTION_CHARSET = utf8

seafdav.conf
[WEBDAV]
enabled = true
port = 8080
fastcgi = true
share_name = /seafdav

seafile.conf
[network]
port=12001

[fileserver]
port=8082

Set maximum upload file size to 20GB.

max_upload_size=20000

Set maximum download directory size to 20GB.

max_download_dir_size=20000

[database]
type = mysql
host = 127.0.0.1
port = 3306
user = seafile
password = (secret)
db_name = seafile-db
connection_charset = utf8

seahub_settings.py
SECRET_KEY = “(secret)”

DATABASES = {
‘default’: {
‘ENGINE’: ‘django.db.backends.mysql’,
‘NAME’: ‘seahub-db’,
‘USER’: ‘seafile’,
‘PASSWORD’: ‘(secret)’,
‘HOST’: ‘127.0.0.1’,
‘PORT’: ‘3306’,
‘OPTIONS’: {
‘init_command’: ‘SET storage_engine=INNODB’,
}
}
}

CACHES = {
‘default’: {
‘BACKEND’: ‘django.core.cache.backends.memcached.MemcachedCache’,
‘LOCATION’: ‘127.0.0.1:11211’,
}
}

EMAIL_USE_TLS = False
EMAIL_HOST = ‘(mymailhost)’ # smpt server
EMAIL_HOST_USER = ‘(mymail)’ # username and domain
EMAIL_HOST_PASSWORD = ‘(mypassword)’ # password
EMAIL_PORT = ‘25’
DEFAULT_FROM_EMAIL = EMAIL_HOST_USER
SERVER_EMAIL = EMAIL_HOST_USER
TIME_ZONE = ‘Europe/Berlin’
SITE_BASE = ‘https://cloud.mydomain.de
SITE_NAME = ‘Falks Seafile’
SITE_TITLE = ‘Falks Seafile’
SITE_ROOT = ‘/’
USE_PDFJS = True
ENABLE_SIGNUP = True
ACTIVATE_AFTER_REGISTRATION = False
SEND_EMAIL_ON_ADDING_SYSTEM_MEMBER = True
SEND_EMAIL_ON_RESETTING_USER_PASSWD = True
CLOUD_MODE = True
FILE_PREVIEW_MAX_SIZE = 30 * 1024 * 1024
SESSION_COOKIE_AGE = 60 * 60 * 24 * 7 * 2
SESSION_SAVE_EVERY_REQUEST = False
SESSION_EXPIRE_AT_BROWSER_CLOSE = False
FILE_SERVER_ROOT = ‘https://cloud.mydomain.de/seafhttp

Enable or disable thumbnails

NOTE: since version 4.0.2

ENABLE_THUMBNAIL = True

Absolute filesystem path to the directory that will hold thumbnail files.

THUMBNAIL_ROOT = ‘/opt/seafile/seahub-data/thumbnail/thumb/’
THUMBNAIL_EXTENSION = ‘png’
THUMBNAIL_DEFAULT_SIZE = ‘240’
PREVIEW_DEFAULT_SIZE = ‘150’

I hope you have a solution or a hint for me where to find the problem.

Thanks a lot
effman


#2

It’s not because 6.2.3 server version it did stop working after iOS 11.2 update.
For some reason the seafile app can’t register gps position.


#3

Hi Calby,
thanks for your answer but the gps is not the problem (i think).
As mentioned i have two servers running. If I enable autoupload for the second server it works (also without gps location)

I reinstalled the app (again) and now i have a different behaviour.
After the first login, the upload seems to work. When i reopened the app, 2 files where uploaded and then the seafile app was frozen. Everytime I start the app now, it does upload 2-3 file before it freezes again.