Issue installing with Docker Compose

Hi,
I used to have seafile installed directly in a CentoOS 7 server. but now I wanted to move into a Docker based installation. This would be a fresh install in a CentOS 7. No need to migrate data.
But for some reason it is not working.
When I do a docker-compose up -d I get both the memcached and seafile-mysql containers. But the seafile one dies. This is what happens:

seafile | *** Running /etc/my_init.d/01_create_data_links.sh…
seafile | rm: cannot remove ‘/var/log/apt’: Directory not empty
seafile | rm: cannot remove ‘/var/log/nginx’: Directory not empty
seafile | *** Booting runit daemon…
seafile | *** Runit started as PID 16
seafile | *** Running /scripts/start.py…
seafile | nginx: [emerg] open() “/etc/nginx/sites-enabled/default” failed (2: No such file or directory) in /etc/nginx/nginx.conf:26
seafile | nginx: [emerg] open() “/etc/nginx/sites-enabled/default” failed (2: No such file or directory) in /etc/nginx/nginx.conf:26
seafile | Traceback (most recent call last):
seafile | File “/scripts/start.py”, line 86, in
seafile | main()
seafile | File “/scripts/start.py”, line 53, in main
seafile | call(‘nginx -s reload’)
seafile | File “/scripts/utils/init.py”, line 70, in call
seafile | return subprocess.check_call(*a, **kw)
seafile | File “/usr/lib/python3.6/subprocess.py”, line 311, in check_call
seafile | raise CalledProcessError(retcode, cmd)
seafile | subprocess.CalledProcessError: Command ‘nginx -s reload’ returned non-zero exit status 1.
seafile | *** /scripts/start.py exited with status 1.
seafile | *** Shutting down runit daemon (PID 16)…
seafile | *** Running /etc/my_init.post_shutdown.d/10_syslog-ng.shutdown…
seafile | *** Killing all processes…

Any idea on why this is happening?
I tried both the latest seafile image and the 7.1.5 with same error.

Here is my docker compose file:

version: ‘2.0’
services:
db:
image: mariadb:10.5
container_name: seafile-mysql
environment:
- MYSQL_ROOT_PASSWORD=XXX # Requested, set the root’s password of MySQL service.
- MYSQL_LOG_CONSOLE=true
volumes:
- /opt/seafile-mysql/db:/var/lib/mysql # Requested, specifies the path to MySQL data persistent store.
networks:
- seafile-net

memcached:
image: memcached:1.5.6
container_name: seafile-memcached
entrypoint: memcached -m 256
networks:
- seafile-net

seafile:
image: seafileltd/seafile-mc:7.1.5
container_name: seafile
ports:
- “80:80”
volumes:
- /backup/seafile-data:/shared # Requested, specifies the path to Seafile data persistent store.
environment:
- DB_HOST=db
- DB_ROOT_PASSWD=XXX # Requested, the value shuold be root’s password of MySQL service.
- TIME_ZONE=Etc/UTC # Optional, default is UTC. Should be uncomment and set to your local time zone.
- SEAFILE_ADMIN_EMAIL=XXX # Specifies Seafile admin user, default is ‘me@example.com’.
- SEAFILE_ADMIN_PASSWORD=XXX # Specifies Seafile admin password, default is ‘asecret’.
- SEAFILE_SERVER_LETSENCRYPT=false # Whether to use https or not.
- SEAFILE_SERVER_HOSTNAME=XXX # Specifies your host name if https is enabled.
depends_on:
- db
- memcached
networks:
- seafile-net

networks:
seafile-net:

Inside my image, at /etc/nginx/sites-enabled, after running /etc/my_init.d/01_create_data_links.sh I end up with the following:

??? ? ? ? ? ? default
lrwxrwxrwx 1 root root 37 Apr 29 14:47 seafile.nginx.conf -> /shared/nginx/conf/seafile.nginx.conf

The script is doing the following command:

ln -sf /shared/nginx/conf/seafile.nginx.conf /etc/nginx/sites-enabled

shouldn’t it be:

ln -sf /shared/nginx/conf/seafile.nginx.conf /etc/nginx/sites-enabled/default

Otherwise I end up with a non existing file and nginx fails to start.

Tnx