Issue with iOS 10.3.2?

I have an Iphone and an Ipad Pro. The latter, with ios 10.3.2 and seafile pro client, connects to the server but does not browse (or show) any folder. On the other hand the iphone (with ios 10.3.1 and the same Seafile Pro version) works perfectly well.

1 Like

This is the error found in the logs from apache in the Seafile server (v 6.0.9) where that Ipad connects.
[19/May/2017:12:35:16 -0300] “GET /api2/events/?start=0 HTTP/1.1” 404 1831 “-” “SeafilePro/6 CFNetwork/811.5.4 Darwin/16.6.0”

Besides, no other Seafile client on that server has ever sent that GET.

I’ve the same problem with the iOS App.

Before the iOS Version 10.3.2 the App worked fine, all functions were greate, it connected to the server. No Problems!
After the iOS Update, the App Version 2.5.8 and 2.5.9 don’t do it’s job!

My Server is a raspberry Pi (Vers. 6.0.8) with a ngnix Web-Server (https), and all other connected devices works very well.

So i’ve reinstalled the app on the iPhone, connected to my own Server, accepted the own SSL Certificate and the App connects to the server and try’s to load the file-list. After some seconds a message appears it say’s “Failed to load files”.

When i switch on the settingoption “accept all unknown certificates”, than it works a little bit better, because in this case the app loads the file-list, but doesn’t show any content of the file’s as like as PDF, JPG,…

Could you please fix this issue?

Same here!
Productive Server is still running on version 6.0.9 and was actually working (after the app update) until i’ve reinstalled the app. With cleared cache im getting the same failures.
Updated iOS as well.

Same issue reported in this Thread:

German Thread.

I have repeated your procedure: reinstalled the App (2.5.9 version) in my Ipad Pro (with iOS 10.3.2), setting option “accept all unknown certificates” with the same outcome: a bit improved functionality showing the file-list however still not downloading any content. NONETHELESS, the most striking fact is that after finally installing iOS 10.3.2 in my iPhone -not without hesitation since I did not want to lost the access to my Seafile folders- the App (also version 2.5.9) remains working fine!. All the settings are exactly the same (ipad and iphone). It is really hard to explain…

Exactly same problem on iphone SE and iphone 6, the upload on server is ok , download any file and icone prevew not download after 2.5.8 and 2.5.9 version update, on 2 different server windows version and linux (debian). the sync tool on pc and the app android tablet work perfectly

OK. I think I am having a similar issue. I have the client version 2.5.9. I can log on to the server i have hosted. It will upload pictures off my phone but I am unable to download to view them in my app. I can log on to the web application either on the phone or on my laptop. Everything else works and authenticates. However I just can’t view the files in the client.

Is this a client issue with iOS or do I have a server setting that is wrong. Can someone confirm this? Many of the terms being used are similar and I wonder if everyone is also having issues with their iOS clients for seafile.

this seems to be an issue since iOS 10.3.2 as previous version works just fine.
From what I read the WebKit had some updates/changes.

Will have to wait for a new version / response from devs

Hi Johm4526 Your server is probably ok, the problem is the ios app 2.5.8 and 2.5.9 Version i’am exactly the same problem. my Android app on my tablet is ok on the same server.

OK. I appreciate it. That really helps. I usually I assume I broke something :slight_smile:

1 Like

FWIW, I observe the same problem - no folders shown - since a few days, but my phone was on iOS 10.3.1 until right now. The most recent change was the update to client version 2.5.9 although I cannot definitely confirm that the problem started exactly at that point.

I can reproduce the problem after reinstalling the app. Only upgrading the app doesn’t reproduce the problem on my phone. We’ll look into this problem.

Just installed seafile new on an Iphone with IOs 10.3.1 (!)

I guess it is the same bug. No File Download. At least no preview of pdf and image files.

I know you do good work. So take your time and do some magic :smiley:

So, it looks like they have fixed the problem:

Thank you very much @lilthree and @poetwang for fix the bug!
I’ll hope the next update comes soon.

Best regards,…

1 Like

Now it is working fine! Thanks a lot to the developer team. Just a short remark:
I had to
1)remove app
2) reboot the device
3) perform a fresh install
Just upgrading did not work.

“SeafilePro/6 CFNetwork/811.5.4 Darwin/16.6.0” > SDWebImageManager lib User-Agent format
[[SDWebImageManager sharedManager].imageDownloader setValue:userAgent forHTTPHeaderField:@“User-Agent”];

Suggest you can install an app to control these data for your iOS

Of course, you can.

So is it an iOS issue or is it a compatibility issue with the iPad models? How did it work with iPhone?