LAN works great, WAN doesn’t work at all

I managed to get everything set-up perfectly
fine. I have seafile and seahub running, and able to access
seafile.mydomain.com from
browser on PC, laptop, and mobile. Both Windows and Android client apps
work. It’s also insanely faster compared to what I was able to achieve
with OwnCloud.

However, for some reason it is incredibly slow or completely
non-responsive when trying to access seafile from a WAN connection. I
have both 8001 and 8082 ports forwarded (set the config in seafile to 8001 as 8000 is already taken by Wallabag) to the device running seafile.
The majority of the time I get a ‘connection timed out’ error page in my
browser when trying to access seafile. If the connection does not time
out I can sometimes manage to log in but get a ‘permission error’ when
trying to access any libraries. Given this happens after a long time, I
am guessing it’s a case of the connection timing out again. On the
Android device I get ‘Error when loading folder’, again likely due to
connection timing out. Strangely, for some reason whilst seafile tries
to load all my other services are inaccessible as well until the seafile
connection times out - even the services that are running on different
devices but only share the domain through port forwarding.

Any ideas what I could be doing wrong or need to change to fix this?

Cheers,

Abe.

(Apologies for cross-posting this from the other forum - didn’t realise there were separate German and English forums!)

Spent the majority of this evening going back through my whole setup and managed to determine the problem. For some reason Seafile is being treated as a DoS attack by my router. Absolutely no idea why. I run a host of servers, including subsonic, plex and in the past owncloud which must create similar traffic. With the DoS protection off uploads via my mobile connection appear pretty good and no connection timeouts.

My router is a ASUS RT-AC66U if anyone else has similar issue or devs want to figure out why its getting flagged.

Cheers.

Although you’ve appartenly found the reason for the issues, I’d have some questions:

  • Are you using it behind an nginx?
  • If not: Don’t you are afraid because of the security issue because you are exposing your network by forwarding those ports in your router to an insecure non-https connection?

Yeah, it could be possible that your router treat seafile traffic as DoS attack because it uses a non 80/443 port. Use nginx may improve this.

1 Like

I am in the process of setting everything on one of my devices back up after a hardware failure - which is also why I took it as an opportunity to try out seafile. Only opening the ports during my testing. This weekend I am getting round to setting up ssl certificates on everything and then setting all my apache virtual hosts to *:443 with the certificates and pass all *:80 traffic to the *:443.

1 Like