Libraries not visible. No success with seaf-fsck --export


#1

Hi,

suddenly my libraries are gone. Seafile Server (Web GUI etc) runs fine. I see a “Please contact administrator message …” instead where normally my libraries would be.

So I went to run a seaf-fsck --export for different libraries but all I got is:

[11/30/17 17:14:41] fsck.c(928): Scanning available commits for repo 46a9b943-5a74-4a9e-a8f4-xxxxx…
[11/30/17 17:14:41] fsck.c(935): No available commits for repo xxxxx, export failed.

MySQL databases is up an running.

So what is happening and how can I fix?

Any help is really appreciated. Thank you


Server OS: debian 9
Seafile Server: 6.1.2
Web Server: nginx-1.10


#2

Out of the black this looks like a filesystem problem.
Can you do a filesystem check/repair?


#3

It could also be a permission issue. Make sure all files are owned by the correct user (that one you run Seafile as)


#4

Hi,

finally I had the time to try your proposals out and indeed it was something between file permissions and access toa NFS share. But why it suddenly working it is still not clear but now it works. Thank you for help.