Library cannot open, got error "Failed to decompress dir object" after upgrade

  • I am running Seafile on Raspberry pi.
    -Yesterday I upgraded from 6.1.1 to 6.1.2, followed the Seafile minor upgrade steps, firstly stopped the Seafile services, then run the minor-upgrade.sh, then restart the Seafile. Seafile started fine.
  • But then when I tried to upload a folder to a library “Doc” through browser interface, got error (something like invalid index… I don’t remember exactly), also tried up update a txt file through browser, got same error, seemed cannot do any file/folder update.
  • Then I reboot the Raspberry pi server, after reboot, I can edit the text file and submit and save, the problem seemed go away ( The text file is in another library other than “Doc”)
  • Then I found I can not open the library “Doc” anymore, when I click the library “Doc”, it cannot open the files/folders list. The “Details” can still show the number of files and size in the library.
  • I checked the seafile.log, found error : Empty input for zlib, invalid …/common/fs-mgr.c(1700): Failed to decompress dir object 1ceba4be538fcbc447670088f7743f2440931291.
  • During this process, there was no server abnormal shutdown, and the hard drive is a new hard drive. So it should not be hard drive corruption or OS error.
  • I tried seaf-fsck.sh, it reported 7 " Failed to decompress fs object" error, out of which, one is the same object number, Failed to decompress fs object 1ceba4be538fcbc447670088f7743f2440931291.

Any suggestion would be really appreciated!

1 Like

Hi,

I checked the seafile.log, found error : Empty input for zlib, invalid …

not sure but maybe you need this package or update the package
sudo apt-get install zlib1g-dev
I did a list about eventually necessary packages on a raspberry. Check

Good luck

Thanks Daniel for your message. I checked, the zlib1g-dev package had already been installed, and I tried to use command “apt-get install zlib1g-dev”, got message "zlib1g-de is already the newest version.

The “Doc” library still cannot open, when I click on it in browser, the page is just blank, no files and folder listed. In the log file there are a bunch of same error message:
[09/01/17 17:12:35] Empty input for zlib, invalid.
[09/01/17 17:12:35] …/common/fs-mgr.c(1700): Failed to decompress dir object 1ceba4be538fcbc447670088f7743f2440931291.

I have several other libraries, those libraries are working fine, only this one library “Doc” doesn’t work.

Thanks,