Links in emails anpassen


#1

Hallo,
ich bin sehr froh, dass ich es geschafft habe eine Seafile 6.2.5 Installation auf einem Raspi am laufen zu haben.
Alles hat gut geklappt.
Nur eine Sache kriege ich nicht hin und wäre sehr dankbar für Eure Unterstützung.
Wie bekomme ich es hin, dass in emails der Link für Anmeldung, zu Freigaben usw. den Port nicht enthält?
Wenn ich z.B. auf “Passwort vergessen” klicke enthält die email einen Link mit cloud.meinedomain.de:8000/
Obwohl die Service_URL den Port nicht enthält und ich mich auch ohne anmelde.

Installation:
Pi 3
Nginx
SSL mit Lets Encrypt
Seafile 6.2.5

Dyndns mit CNAME Eintrag auf Domain

MbG
Thomas


#2

Wurde (ich meine) SITE_URL in seahub settings py gesetzt?


#3

Hallo Sven,

nein SITE_URL ist in der seahub_settings.py nicht eingetragen. Einen solchen Parameter habe ich in der Doku auch nicht gefunden.
Nur SITE_NAME, SITE_TITEL und SITE_ROOT

MfG
Thomas


#4

Dann müsste es SITE_NAME sein.

Ich hatte angenommen, das die URL aus den E-Mails daher kommt.

Wenn dem nicht so ist gäbe es noch die Möglichkeit die E-Mail Templates anzupassen.


#5

Hallo,

so ich habe mir nun noch einmal meine gesamte Konfig angeschaut, ohne sichtbares Ergebnis.
Zur Sicherheit habe ich die Berechtigungen auch noch einmal neu gemacht und siehe da nach dem Neustart funktioniert alles wie gewünscht.

Danke

MbG
Thomas