Local Data Corrupt


#1

Hello,

I downloaded a clean zip file containing png pictos yesterday. I extracted them on our Seafile Server via Seadrive.
That’s when Seadrive stopped syncing with Seafile.

I get the error "Local data is corrupt".

The Log gives me this:
[08/30/17 11:45:55] sync-mgr.c(561): Repo ‘BEE SECURE 4’ sync state transition from ‘synchronized’ to ‘uploading’.
[08/30/17 11:45:55] http-tx-mgr.c(3850): Upload with HTTP sync protocol version 1.
[08/30/17 11:45:55] http-tx-mgr.c(1117): Transfer repo ‘f71511b0’: (‘normal’, ‘init’) --> (‘normal’, ‘check’)
[08/30/17 11:45:55] http-tx-mgr.c(1117): Transfer repo ‘f71511b0’: (‘normal’, ‘check’) --> (‘normal’, ‘commit’)
[08/30/17 11:45:55] http-tx-mgr.c(1117): Transfer repo ‘f71511b0’: (‘normal’, ‘commit’) --> (‘normal’, ‘fs’)
[08/30/17 11:45:55] http-tx-mgr.c(1117): Transfer repo ‘f71511b0’: (‘normal’, ‘fs’) --> (‘normal’, ‘data’)
[08/30/17 11:45:55] fs-mgr.c(591): [fs mgr] Failed to read file ff3242fc6806d32317faf4a17f33317d4ebc6a48.
[08/30/17 11:45:55] http-tx-mgr.c(3586): Failed to get file ff3242fc6806d32317faf4a17f33317d4ebc6a48 in repo f71511b0.
[08/30/17 11:45:55] http-tx-mgr.c(1117): Transfer repo ‘f71511b0’: (‘normal’, ‘data’) --> (‘error’, ‘finished’)

Can someone help me with advise?

Thanks

Jeff


#2

Looks like it failed to receive an object.

Can you have a look at seafile-data/fs/ff/3242fc6806d32317faf4a17f33317d4ebc6a4 (on the server - as long as you own it)

Is the file owned by the correct user, is it accessible?


#3

I solved the problem.

I deinstalled SeaDrive Desktop Client.
I removed local copy of our Seafile Server.
I re-installed SeaDrive Desktop Client.
The Auto-Syncing of Seafile Server created a new local copy that didn’t have the local corrupted data issue.

Thank you anyways.


#4

@daniel.pan I think this happens too often and there is an issue. The client does not reliably recovers automatically from such error cases.


#5

There was a similar bug in some old version of SeaDrive. Are you using the latest version?


#6

My seadrive clients fails every day with the same error (local data is corrupt), i found at least 1 file that is on om my local storage but not on my server repository, now i am not shure if there are more file which are going to be “lost” when i just delete en reinstall seadrive (i have the latest version installed).

Anybody any advise??

Kind Regards
Gerard


#7

Your issue may not be related to this bug. What do you see in seadrive.log? An easy way to fix this problem is logout and login to the account. Any files that are not yet uploaded will be uploaded again. No data will be lost.


#8

I appreciate your advise and effort, but be aware i lost several document that where in the cache.

Kind Regars
Gerard


#9

Do you have anti virus software running? It may remove “suspicious” seafile metadata files.