Local sync fails for some files (after windows update?)

Hi all,

after using seafile without problems for a couple of years, the seafile client on my desktop pc stopped working properly. Some files are not synced to my local directories anymore. I noticed that this occurred after installing a windows update a couple days back on my desktop pc, while on my notebook, which was not updated yet, the library are still correctly synced. The installed updates are the following:

1: October 13, 2020-KB4578968 Cumulative Update for .NET Framework 3.5 and 4.8 for Windows 10 , version 20H2

2: October 13, 2020—KB4579311 (OS Build 19041.572)

  1. Security Update for Adobe Flash Player: October 13, 2020

The syncing works properly for the majority of files, but for some it fails. See e.g., the following file Ue2_RT1.pdf in the directory 70_Lehre. Within the seafile client’s “cloud file browser”, all data is displayed correctly, but no copy to the local directory on my drive is created. Within the windows explorer the considered folder is empty and it is indicated that the folder is not entirely synced. The overview of the seafile client reports a proper synchronisation of the library RT anyway:


I have tried to reinstall seafile, deleted all data from the directories and resynced the library but the problem persists. In the seafile.log files “permission denied” errors like the following are reported:

[10/18/20 23:05:18] …/common/fs-mgr.c(314): Failed to rename C:/Users/flo/Seafile\RT/70_Lehre/Ue2_RT1_L.pdf~ to C:/Users/flo/Seafile\RT/70_Lehre/Ue2_RT1_L.pdf: Permission denied. Checkout server version as conflict file.
[10/18/20 23:05:18] …/common/fs-mgr.c(322): Failed to rename C:/Users/flo/Seafile\RT/70_Lehre/Ue2_RT1_L.pdf.sbak to C:/Users/flo/Seafile\RT/70_Lehre/Ue2_RT1_L.pdf: No such file or directory. Failed to restore backup file.
[10/18/20 23:05:18] repo-mgr.c(4624): Failed to checkout file C:/Users/flo/Seafile\RT/70_Lehre/Ue2_RT1_L.pdf.


The end of the seafile.log file is given by:

[10/18/20 23:05:40] http-tx-mgr.c(1157): Transfer repo ‘34789167’: (‘normal’, ‘data’) --> (‘finished’, ‘finished’)
[10/18/20 23:05:40] clone-mgr.c(680): Transition clone state for 34789167 from [fetch] to [done].
[10/18/20 23:05:40] sync-mgr.c(1340): File syncing protocol version on server serveradress is 2. Client file syncing protocol version is 2. Use version 2.
[10/18/20 23:05:41] sync-mgr.c(582): Repo ‘RT’ sync state transition from ‘synchronized’ to ‘committing’.
[10/18/20 23:05:51] repo-mgr.c(3854): All events are processed for repo 34789167-d437-4c67-8a76-26ff5815c7f6.
[10/18/20 23:05:51] sync-mgr.c(582): Repo ‘RT’ sync state transition from ‘committing’ to ‘initializing’.
[10/18/20 23:05:51] sync-mgr.c(881): Removing blocks for repo RT(34789167).


The seafile_ext.log is showing the following message:

[20/10/19 09:54:30] /C/dev/seafpkg/build/seafile-msi-build/seafile-shell-ext-7.0.10/extensions/ext-utils.cpp(line 184) checkLastError: connection broken with error: The pipe is being closed.

[20/10/19 09:54:30] /C/dev/seafpkg/build/seafile-msi-build/seafile-shell-ext-7.0.10/extensions/applet-connection.cpp(line 143) writeRequest: failed to send command: no error


Is anyone else experiencing this issue? Is anyone having an idea how to solve this issue?

Thanks in advance!
Flo

I found out that this error was caused by my virus protection software (not sure why this suddenly happened and only some files are affected). deactivation/creating exceptions in the antivirus software for seafile resulted in a proper synchronization.

Which anti virus protection software do you use? We see problems currently with Avast.

same here. in the properties you can disabled the blocking of seafile. at least for me this worked…

1 Like

OK, good to know. Please see my post for reference: Seadrive 2.05 dropped by avast antivirus