MariaDB upgrade from v5.5.68 to v10.6.5 failed

I spoke too soon in another post where I said the upgrade worked fine. Existing Seafile client worked fine but Seadrive stopped working and when I try to open the website, I get:


I’ve restored the backup before the upgrade and restored recently modified files so back in action.

Any ideas though what the problem is though as I need to get 10.6 on this server for another app?

I’ve downloaded the logs and the following errors are occurring in seahub.log. Don’t know much about django but is Seafile v8 Pro actually compatible with MariaDB v10.6.5?

Traceback (most recent call last):
  File "/data/seafile/seafile-pro-server-8.0.15/seahub/thirdpart/django/db/backends/base/", line 217, in ensure_connection
  File "/data/seafile/seafile-pro-server-8.0.15/seahub/thirdpart/django/db/backends/base/", line 195, in connect
    self.connection = self.get_new_connection(conn_params)
  File "/data/seafile/seafile-pro-server-8.0.15/seahub/thirdpart/django/db/backends/mysql/", line 227, in get_new_connection
    return Database.connect(**conn_params)
  File "/usr/local/lib64/python3.6/site-packages/MySQLdb/", line 130, in Connect
    return Connection(*args, **kwargs)
  File "/usr/local/lib64/python3.6/site-packages/MySQLdb/", line 185, in __init__
    super().__init__(*args, **kwargs2)
MySQLdb._exceptions.OperationalError: (2019, "Can't initialize character set utf8 (path: /usr/share/mysql/charsets/)")

Later… giving up as going around in circles. Tried upgrading to v9.0.3 which worked fine but same problem after upgrading MariaDB to v10.6.5. Restoring back to MariaDB v5.6.

Out of interest, whilst trying to resolve this I found a reference to these MySQL scripts:

Do you somehow have to run these manually or does the upgrade script run them against the databases directly?