Migrating to docker

I currently have Pro 8.0.17, installed as traditional way, running on Almalinux 8. Trying to migrate to docker.
I followed steps here After running “docker-compose up -d”, the script pulled the latest version, creating folders…

Status: Downloaded newer image for docker.seafile.top/seafileltd/seafile-pro-mc:latest
Creating seafile-mysql … done
Creating seafile-elasticsearch … done
Creating seafile-memcached … done
Creating seafile … done

No error appears. However, after that, seafile, seahub are still dead. Checked the nginx config in /opt/seafile-data/nginx/conf/seafile.nginx.conf, changed example.seafile.com to my domain. Reloaded nginx, run “docker-compose up -d” again, but seafile and seahub are still not working.

I noticed that /shared is still not existing. So, the questions are:

  1. Do I need to create /shared with all sub-folders manually?
  2. With seafile related folders, which user can be applied? seafile (as the owner of the current traditional installation), or root?
  3. Any idea why seafile and seahub are not working, when there is no error?

Thank you.

Anyone can help on this, please?

Most likely there is an issue in your docker compose yaml. Are you passing through the ports?

I used windows but yes I needed to create the folders ahead of time.

I too failed to load seahub at first yet saw no errors. It was a bad config in my compose.