[Mobile] Uploading multiple pictures doesn't work

Yesterday I installed on Android Seafile app with intuitive need of uploading pictures from my phone to our company’s Seafile disk. And how much I was surprised when it turned out only one picture from all is transfered! Yes… I tried few time ans always just one is uploaded :frowning:

I’ve found workaround that its need to go first to Gallery mark all pictures and then send them to Seafilke - then it works. It uploads all pictueres. But its just workaround! It should work from app right away!

I know this is open source. I know I don’t have right to complain but for God sake that app has version 2.2.5 probably… how is possible that developers has written probably dozen version of it and still they haven’t implemented MOST BASIC featues like uploding multiple pictures to Server ?? Tell me… what is the puprpose of tandem: mobile app + online disk exactly ?? Because in this case I don’t know.

Multiple Photo/Video upload worked the last years since I use seafile pro like a charm, no problem whatsoever…

But now, ,I also have the same problem with Photo/Video upload
seafile pro App on iPhone 2.9.13

I have recently upgraded my iPhone 6S to iOS 14.3
It seems Apple has changed something in the selection logic of Photos?
I can make a selection of what I want to upload but once this is done, the selection is “stuck” I can not change the selection anymore and I can no longer upload Photos / Videos.

I also tried the other way, going to Photos and from there send to seafile - here I am limited to only a few Photos/videos (10 or so) - sometimes it even does not upload all 10 (unreliable)

It is essential that Photos/Videos can be uploaded as before (as many as I like)
I assume it has to to with the new iOS?
Maybe the seafile app needs to be changed as well?
I am now unable to upload and I’m stuck with the screens attached if I want to upload in seafile pro - I can not alter the selection anymore - killing the app did not help

In my case we have Seafile Server Open Source version

The android version can work in my case. Can you try the latest version 2.2.32 by downloading it from https://github.com/haiwen/seadroid/releases ?

Ok, I’ve made mistake :frowning: But maybe this is good news. Mobile app Seafile downloaded even from Play Store in version 2.2.25 works very good. And it uploads multiple pictures like a charm.

The mistake was I pointed out him source of pictures some apllication “Pictures” on my phone not Gallery! Thats why he uploaded only 1 pic. But from Gallery all is working and all pictures are sent.

So big apologies for developers. I give back honor to you and once again multiple thanks for developing as for now - very good soft which is Seafile.


For some reason after upgradeing iOS Seafile only had access to “Selected Photos”
I had to give back access to “All Photos” and it worked again