Moved folder into Seafile, contents is now corrupt?

I am working on a Mac. I moved some files and folders to an existing subfolder within an already populated library to back them up before I did a clean install of OS X 10.11.6 on the iMac. I have now reinstalled the OS, installed and logged into seafile, tried to copy my files back onto my desktop but now the old folders have a blank document icon in place of the folder icon. When I try to open the folder, it opens in TextEdit instead and looks ike this:

bookmark88ćΩ3ÅΩArs/SLUsersSarahaDesktopuntitled folder 0@hEvEÅΩpÄê†Aº%ƒïˆ file:///UntitledÄÅ=tA∏(â¬$4EEEE744-2BBF-39D0-BAC6-14D791A8A104ÅÔÔ/0dnibrdlf»icns»TOC his32’s8mkic11Ωil32ñl8mkic12Ôic07C∏ic13Ú¨ic08Ú¨ic14;˛ic09;˛ic10
9”is32’çtqqputyÜaqñíìëózxÖosouttvsuuvqssvpbhdhdihcgfiiecjceljljjllihjiihjaahkghjijkjhmgik\kmmikoqlkhlmkk_]nqqmoqokplkonp^]nuonsprorqssorZYsvqturvqvurutsXVrÅwvvuutruvuUTtxxvuywwsvxtwuTnÄïÄíòìñîìïîílOSRSSQPRUPQTOSSPçç≥ªººΩº≠Üaª‹‹›‹‹»ßÖ)∫ººªΩΩºΩ∫ºø∫ºΩ∫µ≤ …À…À »À…ÃÃÀ …¥µÕà À ÃÀÀ»Ä ÃÃ≥±ÅÀÃÕÕœÀÄÕÃÃ≥ØÃŒœŒÃœŒÀŒÀŒŒÕÃ≥±Œ––ÅœÕÄœÕÕœØ≠ŒœÕŒ–—–ŒœŒÄ–œÆØ—œÇ—––—“–“–ب““––“–“Ä–“—–“´™–“””—”—“—‘”–—“ƪ››Å€‹‹€€Ä‹›π¢®£•®¶§©©•ß©ß¶®£ççœfi‹€›‹≈Ü€Åˇ˝ÈªÖ‹›fi››fi›‹‹fi€›‹fifi‘◊ıâ¯ı◊ŸÖ¯˜Ç¯Ÿ◊ã˘◊’ã˘◊’ã˘÷÷ã˘÷÷ã˙‘‘ã˙’”ã˙’€ã¸€≈ÕÕ–œÃÕœœÃŒŒœœÕ«çs8mkÆˇˇˇˇˇÉˇˇˇˇˇˇˇ@ˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇ∂ˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇ

How can I get this back? What has happened here that has caused these folders to become corrupt like this?? Its really important I get these folders back

It looks like ALL files in there are corrupt or incomplete. they are all around a few hundred KB, a couple of folders are around 1MB but still, none of them are opening at all. ALL are corrupt. Weird thing is that when I moved them across, I waited until they all had a green tick on them which I believe makes sense as all the folders are actually in seafile which means they did Sync.

Here is a screenshot of the Library when viewed from the Seaflie Web Interface.

(image hosted on Imgur) http://imgur.com/a/Y6CL6

As you can see, files of the same format are all the same size PDFs = 294.4KB, JPG = 914.2 KB, Folders are 202.7 or between 1-2MB in size.

Some more information:

Client was on latest Mac version 5.1.4.
Seafile Server is on 5.0.4

The screenshot seems to be deleted?

You can first check whether the library is corrupted on the server. See http://manual.seafile.com/maintain/seafile_fsck.html

I have amended the link. should be working now.

You can first check whether the library is corrupted on the server. See http://manual.seafile.com/maintain/seafile_fsck.html

Yes, I am planning to do that today.