Nach Upgrade von 6.2.2 to 6.3.4 auf Raspi mit Nginx kommt “Page unavailable”

server

#1

Ich habe schon im englischen Teil gepostet, aber vielleicht findet sich ja auch Jemand der besser auf deutsch weiß wo das Problem ist :wink:

Ich habe kürzlich mein System (Raspi) von Jessie zu Stretch aktualisiert. Seither funktioniert Webdav nicht mehr, aber da ich es eh nicht mehr benutze, habe ich mich auch nicht auf Fehlersuche begeben.
Nun habe ich aber von 6.2.2 auf 6.3.4 geupdated und nun funktioniert das Webinterface nicht mehr, was wohl am Wechsel von fastcgi zu WSGI liegt.
Soweit ich das überblicken konnte habe ich alles nötige in der nginx config geändert und fastcgi =false in der ccnet.conf geändert, aber es will trotzdem nicht.

Sobald ich die seite im Browser öffne kommt folgendes

Page unavailable
Sorry, but the requested page is unavailable due to a server hiccup.
Our engineers have been notified, so check back later.

Derweil funktionieren aber die Seafile Clients, der rsync backup Server sowie der Baikal Kalender Server, die auch darauf laufen, problemlos.
Ich habe nun schon probiert eine minimale “saubere” nginx config zu benutzen, die nur so aussah wie in den Anleitungen, aber daran scheint es nicht zu liegen.
Ich habe auch probiert in der gunioorn.conf auf bind = "0.0.0.0:8001" umzustellen und ich habe
SITE_BASE = "https://vapricloud.com"
File_Server_Root = "https://vapricloud.com/seafhttp"

in der seahub.settings.py geändert wie es hier vorgeschlagen wurde, aber das hat nichts gebracht

Ich habe aber festgestellt, das ich über den rechtsclick im Client “Im Webbrowser ansehen” auf die Webseite komme und eingeloggt bin. Sobald ich aber auf “System Admin” im Menu gehe kommt wieder obige Fehlermeldung. Ebenso beim Logout.

Der Fehlermeldung nach sieht es nicht nach einem Nginx Fehler aus und mir scheint es so, als würde die Basis Url irgendwie nicht richtig weitergegeben.
Ich finde den Fehler aber einfach nicht.

Hier mal meine configs
nginx config:

server {
listen 443;
ssl on;
ssl_certificate /etc/nginx/ssl/vapricloud_com/vapricloud_com.crt;
ssl_certificate_key /etc/nginx/ssl/vapricloud_com/vapricloud_com.key;
server_name vapricloud.com;
ssl_prefer_server_ciphers on;
error_page 497 https://$host:$server_port$request_uri;
client_max_body_size 20G; # set max upload size

#baikal
root /var/www/html; #
rewrite ^/.well-known/caldav /dav.php redirect; #
rewrite ^/.well-known/carddav /dav.php redirect; #
charset utf-8; #

location / {
  proxy_pass         http://127.0.0.1:8000;
  proxy_set_header   Host $host;
  proxy_set_header   X-Real-IP $remote_addr;
  proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
  proxy_set_header   X-Forwarded-Host $server_name;
  proxy_read_timeout  1200s;

 # used for view/edit office file via Office Online Server
 client_max_body_size 0;

 access_log      /var/log/nginx/seahub.access.log;
 error_log       /var/log/nginx/seahub.error.log;
}       

#baikal
location ~ ^(.+.php)(.)$ {
try_files $fastcgi_script_name =404;
fastcgi_split_path_info ^(.+.php)(.
)$;
fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param PATH_INFO $fastcgi_path_info;
include /etc/nginx/fastcgi_params;
access_log off;
}

location /seafhttp {
    rewrite ^/seafhttp(.*)$ $1 break;
    proxy_pass http://127.0.0.1:8082;
    client_max_body_size 0;
    proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;

    proxy_connect_timeout  36000s;
    proxy_read_timeout  36000s;
    proxy_send_timeout  36000s;

    send_timeout  36000s;
}

location /media {
    root /home/user/haiwen/seafile-server-latest/seahub;
}

location /seafdav {
    fastcgi_pass    127.0.0.1:8080;
    fastcgi_param   SCRIPT_FILENAME     $document_root$fastcgi_script_name;
    fastcgi_param   PATH_INFO           $fastcgi_script_name;

    fastcgi_param   SERVER_PROTOCOL     $server_protocol;
    fastcgi_param   QUERY_STRING        $query_string;
    fastcgi_param   REQUEST_METHOD      $request_method;
    fastcgi_param   CONTENT_TYPE        $content_type;
    fastcgi_param   CONTENT_LENGTH      $content_length;
    fastcgi_param   SERVER_ADDR         $server_addr;
    fastcgi_param   SERVER_PORT         $server_port;
    fastcgi_param   SERVER_NAME         $server_name;

    fastcgi_param   HTTPS               on;

    client_max_body_size 0;

    # This option is only available for Nginx >= 1.8.0. See more details below.
    #proxy_request_buffering off;

    access_log      /var/log/nginx/seafdav.access.log;
    error_log       /var/log/nginx/seafdav.error.log;

}
}

ccnet.conf

[General]
USER_NAME = VapriCloud
ID = 1b873db6cbfbb5ea3ab12a6987136923b1839b9d
NAME = VapriCloud
SERVICE_URL = https://vapricloud.com:8001

[Client]
PORT = 13419

gunicorn.conf

import os

daemon = True
workers = 5

default localhost:8000

bind = “0.0.0.0:8000”

Pid

pids_dir = ‘/home/seafile/pids’
pidfile = os.path.join(pids_dir, ‘seahub.pid’)

for file upload, we need a longer timeout value (default is only 30s, too short)

timeout = 1200

limit_request_line = 8190

seafdav.conf

[WEBDAV]
enabled = true
port = 8080
fastcgi = false
share_name = /seafdav

seafile.conf

[fileserver]
port=8082

Set maximum upload file size to 999M.

#max_upload_size=999

Set maximum download directory size to 999M.

#max_download_dir_size=999

seahub_settings.py

SECRET_KEY = “MY KEY”
HTTP_SERVER_ROOT = “https://vapricloud.com:8001/seafhttp
CONSTANCE_DATABASE_CACHE_BACKEND = None

Logs: (Welche in denen sich was geändert hat nach dem Verbindungsversuch)
controller.log

[12/11/18 04:33:56] seafile-controller.c(117): bad pidfile format: /home/seafile/pids/seafdav.pid
[12/11/18 04:33:56] seafile-controller.c(414): failed to read pidfile /home/seafile/pids/seafdav.pid: Success

ccnet.log

[12/11/18 04:31:10] …/common/session.c(398): Accepted a local client
[12/11/18 04:34:21] …/common/session.c(398): Accepted a local client

seafile.log

[12/11/18 04:29:27] http-server.c(173): fileserver: worker_threads = 10
[12/11/18 04:29:27] http-server.c(188): fileserver: fixed_block_size = 8388608
[12/11/18 04:29:27] http-server.c(203): fileserver: web_token_expire_time = 3600
[12/11/18 04:29:27] http-server.c(218): fileserver: max_indexing_threads = 1
[12/11/18 04:29:27] http-server.c(233): fileserver: max_index_processing_threads= 3
[12/11/2018 04:29:27 AM] …/common/mq-mgr.c(54): [mq client] mq cilent is started
[12/11/2018 04:29:28 AM] size-sched.c(96): Repo size compute queue size is 0
[12/11/2018 04:34:28 AM] size-sched.c(96): Repo size compute queue size is 0

seahub.acces.log

109.91.21.49 - - [11/Dec/2018:04:38:10 +0100] “GET /api2/account/info/ HTTP/1.1” 200 250 “-” “Mozilla/5.0”
109.91.21.49 - - [11/Dec/2018:04:39:21 +0100] “GET /api2/events/ HTTP/1.1” 404 35 “-” “Mozilla/5.0”
192.168.2.116 - - [11/Dec/2018:04:41:10 +0100] “GET /api2/ping/ HTTP/1.1” 200 6 “-” “Mozilla/5.0”
109.91.21.49 - - [11/Dec/2018:04:41:10 +0100] “GET /api2/account/info/ HTTP/1.1” 200 250 “-” “Mozilla/5.0”