New Guy be gentle

I just installed Seafile Server with MySQL yesterday on Ubuntu server 16.04 and was having a heck of a time. I could make directories and delete them however uploading and downloading files failed miserably. I started clean and instead of using www.johnhagensieker.com I set up with the internal LAN IP address (192.168.20.6). It worked instantly.

Here’s my thing…I can VPN into my server and contact Seafile by IP address perfectly. However I can’t seem to crack the code on internet facing. I have a pfsense firewall appliance and while I can go to www.johnhagensieker.com:8000 and log into seafile again I have problems with transferring files.

Should I leave it be? Operating behind a VPN without the open ports is inherently more secure I imagine however I’d like to make it work just because now I’m mad and want to make it work.

I can upload conf files if necessary. I think I NAT forwarded ports 8000 and 8082 from my firewall to the server however I can’t telnet in to the IP address 8000 (telnet ipaddress 8000). I’m not a pfsense guru either. I suppose that is ultimately the problem, my NAT firewall.

I can’t help but thinking the redirect is causing the problem. Every
once in a while I’ll click on Download for the seafile tutorial doc that
comes in the package and it redirects to my Apache test page at XXXXXXXXXXXXX I’ve even dabbled with the port numbers

Did you add the port in ccnet.conf ?
SERVICE_URL = http://www.johnhagensieker.com:8000

And in seahub_settings.py ?
FILE_SERVER_ROOT = 'http://www.johnhagensieker.com:8000/seafhttp'


Are you sure your ISP is blocking port 80 ? It’s seems to be your apache welcome page there: www(dot)johnhagensieker(dot)com


And I’m not sure about Apache but with Nginx you only need to open/forward 1 port on your FW/Router.

Correct my page is working correctly. The domain provider is Namecheap and my ISP does block 80. I moved the port to 2100 then on the name cheap advanced DNS page I set up a masked redirect to redirect the traffic to :2100 so all anybody sees is my domain without the port number.

ccnet.conf is configured correctly and I had been putting :8082 in seahub_settings.py however when I change it to :8000 the file says it is uploaded but fails to save. I’ll give that another run though here in a bit.

I finally did the config with Nginx because I had read in about a hundred places that it was easier/better. I tried the Apache config from the Seafile manual previously. I’ve yet to actually understand how I know seafile is operating correctly behind apache or Nginx anyway.