Newbie help - can't get files to upload on web GUI or application - Ubuntu Server 16.04

Hello all! I am brand new to Seafile and I was hoping I could get a little help. So I have setup a Seafile v6.0.9 server behind NGINX. Both of the applications are running on the same Ubuntu server. The web GUI comes up just fine and I can navigate it, but when trying to upload a file, I get an unknown error. On the application side, I can connect to the server using my WAN IP and port, but uploading files larger than a couple of KBs errors out as well. I will list my ccnet.conf and seahub_settings.py below. If anyone could help me out I would greatly appreciate it!

CCNET.CONF

[General]
USER_NAME = ITROOBOX
ID = c2e69c72a8dd042993de588483163f421a1f7463
NAME = ITROOBOX
SERVICE_URL = http://sync.mydomain.com

[Client]
PORT = 13419

[Database]
ENGINE = mysql
HOST = 127.0.0.1
PORT = 3306
USER = seafile
PASSWD = seafile
DB = ccnet-db
CONNECTION_CHARSET = utf8

SEAHUB_SETTINGS.PY

-- coding: utf-8 --

SECRET_KEY = “^qa(6e@qw%agi&gwvkf_d2i8lmcrjkvl6pwq(smya#%h#h=!^e”

DATABASES = {
‘default’: {
‘ENGINE’: ‘django.db.backends.mysql’,
‘NAME’: ‘seahub-db’,
‘USER’: ‘seafile’,
‘PASSWORD’: 'seafile,
‘HOST’: ‘127.0.0.1’,
‘PORT’: ‘3306’
}
}

FILE_SERVER_ROOT = ‘http://sync.mydomain.com/seafhttp

If there is anymore information that I can provide, please let me know. Thanks in advance!

You should chang the value of FILE_SERVER_ROOT on the sysadmin web setting page.

Should that match what is in my Seahub_settings.py?

Yes, it is should be the same as seahub_settings.py

I have changed both values to the same and I still can’t get files to upload properly :confused: Im honestly not sure what I am doing wrong.

Hi @Dylan , I just saw a different setting in my Seahub_settings.py. Maybe try the following (HTTP_SERVER_ROOT instead of FILE_SERVER_ROOT):

SECRET_KEY = "XXXXX"
HTTP_SERVER_ROOT = 'https://sync.mydomain.com/seafhttp'

DATABASES = {
    'default': {
        'ENGINE': 'django.db.backends.mysql',
        'NAME': 'seahub-db',
        'USER': 'seafile',
        'PASSWORD': 'XXXXXXXX',
        'HOST': '127.0.0.1',
        'PORT': '3306'
    }
}

In my environment everything works fine - but I’m on Debian…
Let me know if it works.

In addition, your secret key should stay private. You should create a new one.

I think I might have gotten it fixed. I change the NGINX user to my server admin to test permissions and it looks like it is now uploading files. I have only uploaded files < 1GB. I am now trying a bigger file to make sure those work too. Thank you for you input!!!

BTW: I should have known that given the name “Secret Key” LOL! I will make a new one.

Ok it looks like files < 2GB will upload just fine. Anything greater than that gives me a failed to upload file: unable to write. Any ideas?