Notification Server used by clients?

I tested the websocket in JS and it connects and receives messages just fine and they also get logged in the notification-server.log

my assumption is that the client does not even try to connect to the websocket after calling /notification/ping

A recent test can confirm that. The /notification/ping endpoint get called right on startup of the seafile desktop app but not the /notification endpoint. Nevertheless, the /notification endpoint gets called right when you quit the the app. In the example beneath i opend the app and closed it right afterwards. The second log does not appear when you start it and leave it open. Only on close.

xx.xx.xx.xx- - [04/Aug/2023:23:50:20 +0200] "GET /notification/ping HTTP/1.1" 200 16 "-" "Seafile/9.0.2 (Windows NT)"
xx.xx.xx.xx- - [04/Aug/2023:23:50:33 +0200] "GET /notification HTTP/1.1" 101 44 "-" "-"

Hello @freezziey, can you test this with the latest seafile client 9.0.3.Seafile 9.0.3 has modified some conditional compilation, which may affect the notification of the last version of the client.

Same behavior with 9.0.3

Hello @freezziey , can you set the SEAFILE_DEBUG environment variable to “Notification”, and then try to start the client? There will be more logs about the notification server under seafile.log. For how to set environment variables on Windows, refer to Create and Modify Environment Variables on Windows . After you test it again, you can send the complete seafile.log to

I currently have lost access to the windows client as i mostly use linux. Will do asap.

I checked again on Windows. Now the log appears :slight_smile: On the first Windows test i did not check the log and only tested on linux. That explains that.

The issue remains existant on linux. How can i set the DEBUG log mode on linux for the client?

I fixed it.

I’m running seafile in docker and the host of the notification server is set to by default, i.e. it only listened inside the container. Setting host = in the seafile.conf resolved the issue.