Only first 100 folders being displayed in Firefox


#1

Hi, I have a library with 100+ folders. However only first 100 are displayed in Firefox on both private Seafile CE 6.2.2. server and also on Seafile.cc. It works fine in Chrome though. Is there sth. to be configured server-side, so all the content is displayed in Firefox as well/?


#2

I also did have this issue before.


#3

Hi shoeper, do you recall how did you solve it? Or it simply disappeared by itself?


#4

I did sometimes have it and sometime not. I’m not sure. I mainly use Chrome and sometimes use Firefox. It could be that the issue only occurred with Firefox. At least it would explain why I sometimes had it and often not.


#5

@seafiledevs - can you please resolve this annoying bug? If a library contains 100+ folders, they are still visible, but only in Chrome. However if a folder contains 100+ files, nothing happens. You see just first 100 and that’s it - in every browser. Is it something exotic to have 100+ files in a folder?


#6

I just tested this behaviour with latest firefox in the official seafile demo, no problem. The first 100 entries are loaded when opening the folder. When scrolling down more entries are loaded. No problem.


#7

Thanks for testing, Garfield, however it still does not work for me. Please see the attached screenshots. The only browser I can see more than 100 items is Chrome. I attach screenshots from seacloud.cc. As you can see, folders 101+ do not show up, same for files in a folder.
Browser versions are current. Same behaviour on Windows and Linux.


#8

Please post your nginx config.


#9

Screenshots are made on seacloud.cc :slight_smile: sorry, no way to post the nginx config.


#10

Can confirm this bug. But I think it’s some kind of bug in JS. All our employees can access all file files (it’s loading dynamically after scroll to bottom) on latest chrome. But one have same issue as here. I tried to debug it over Chrome development console but if i scroll at bottom, there’s no XHR request or JS error. It’s just look like everything OK.


#11

Edit: timeout on server side maybe?


#12

I doubt, but who knows. Why it would work in chrome every time and come to a server timeout when other browser is used at it is reproducible?


#13

Are you able to open Developer panel in chrome and check if is there some XHR/AJAX request after you scroll to bottom of page?


#14

Sure, there are requests in both browsers:


#15

And post headers and response of first XHR request(chrome screenshot). I’m not saying that I will repair this, but this is good for developers to faster debug and repair


#16

Here they are:

General
Request URL:https://seacloud.cc/ajax/lib/2de93842-7bdb-4dcd-a2f9-a00a99775e55/dir/?p=%2F&thumbnail_size=48&_=1512635748898
Request Method:GET
Status Code:200 OK
Remote Address:54.221.251.251:443
Referrer Policy:no-referrer-when-downgrade
Response Headers
view source
Connection:keep-alive
Content-Language:en
Content-Type:application/json; charset=utf-8
Date:Thu, 07 Dec 2017 08:45:37 GMT
Server:nginx/1.1.19
Strict-Transport-Security:max-age=15768000
Transfer-Encoding:chunked
Vary:Accept-Language, Cookie
X-Content-Type-Options:nosniff
Request Headers
view source
Accept:application/json, text/javascript, /; q=0.01
Accept-Encoding:gzip, deflate, br
Accept-Language:en-US,en;q=0.9,bg;q=0.8
Connection:keep-alive
Cookie:_ga=GA1.2.179898854.1501587918; sessionid=5d9wg796t2kcnf70ne4kiizp9sjsmvy9; csrftoken=sRRqs6XoEl6EVP7rwgwguRQ09fg3p1Ls
DNT:1
Host:seacloud.cc
Referer:https://seacloud.cc/
User-Agent:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36
X-Requested-With:XMLHttpRequest
Query String Parameters
view source
view URL encoded
p:/
thumbnail_size:48
_:1512635748898
Name


#17

I said first, this is last, this just loading thumbnails :slight_smile:


#18

Of course :slight_smile:

Request URL:https://seacloud.cc/api2/repos/?type=mine&_=1512635748897
Request Method:GET
Status Code:200 OK
Remote Address:54.221.251.251:443
Referrer Policy:no-referrer-when-downgrade
Response Headers
view source
Allow:GET, POST, HEAD, OPTIONS
Connection:keep-alive
Content-Language:en
Content-Type:application/json; charset=utf-8
Date:Thu, 07 Dec 2017 08:45:33 GMT
enable_encrypted_library:True
Server:nginx/1.1.19
Strict-Transport-Security:max-age=15768000
Transfer-Encoding:chunked
Vary:Accept, Accept-Language, Cookie
X-Content-Type-Options:nosniff
Request Headers
view source
Accept:application/json, text/javascript, /; q=0.01
Accept-Encoding:gzip, deflate, br
Accept-Language:en-US,en;q=0.9,bg;q=0.8
Connection:keep-alive
Cookie:_ga=GA1.2.179898854.1501587918; sessionid=5d9wg796t2kcnf70ne4kiizp9sjsmvy9; csrftoken=sRRqs6XoEl6EVP7rwgwguRQ09fg3p1Ls
DNT:1
Host:seacloud.cc
Referer:https://seacloud.cc/
User-Agent:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36
X-Requested-With:XMLHttpRequest
Query String Parameters
view source
view URL encoded
type:mine
_:1512635748897


#19

And response source/body?


#20

Here it is:

[{“permission”: “rw”, “encrypted”: false, “mtime_relative”: “<time datetime=“2017-12-07T08:08:51” is=“relative-time” title=“Thu, 7 Dec 2017 08:08:51 +0000” >56 minutes ago”, “mtime”: 1512634131, “owner”: “user@domain.tld”, “root”: “”, “id”: “2de93842-7bdb-4dcd-a2f9-a00a99775e55”, “size”: 650083805, “name”: “Books”, “type”: “repo”, “virtual”: false, “version”: 1, “head_commit_id”: “a349d333b2b6b01a92e7fd0823243e9176ac26ef”, “size_formatted”: “620.0\u00a0MB”}, {“permission”: “rw”, “encrypted”: false, “mtime_relative”: “<time datetime=“2017-08-28T05:15:58” is=“relative-time” title=“Mon, 28 Aug 2017 05:15:58 +0000” >2017-08-28”, “mtime”: 1503897358, “owner”: “user@domain.tld”, “root”: “”, “id”: “9ccf9e9d-9b37-421b-a9c1-8159c4283664”, “size”: 556583, “name”: “Pub”, “type”: “repo”, “virtual”: false, “version”: 1, “head_commit_id”: “1573fafe5fba60b1b6044e4bc01c973cd29a089b”, “size_formatted”: “543.5\u00a0KB”}, {“permission”: “rw”, “encrypted”: false, “mtime_relative”: “<time datetime=“2016-10-23T05:49:16” is=“relative-time” title=“Sun, 23 Oct 2016 05:49:16 +0000” >2016-10-23”, “mtime”: 1477201756, “owner”: “user@domain.tld”, “root”: “”, “id”: “40ce2896-9aa2-4e63-8368-4f3c20bf6542”, “size”: 201539, “name”: “Moscito”, “type”: “repo”, “virtual”: false, “version”: 1, “head_commit_id”: “75dfb434afe1330177d11c9bcba8eeee0669fa70”, “size_formatted”: “196.8\u00a0KB”}]