Onlyoffice document could not be saved


I’ve been tasked to migrate from 6.1.2 to 9.10. It took me time, but I was able to achieve the task. Now, my customer want to use onlyoffice with his new setup containing 1.5Tb of data over millions of files.

Here’s some info

  • Seafile server 9.10 native (no container) in a proxmox virtual machine
  • seafile-data reside on an NFS mount point to a QNAP NAS
  • seafile is working fine, read/write, etc
  • onlyoffice installed on the same VM inside a container
  • onlyoffice main page is working fine at http://ip_address:88/welcome
  • only office example are working file using http://ip_address:88/example
  • by using the nginx reverse proxy configuration, onlyoffice is also working fine with https://ip_address/onlyofficeds/welcome/
  • When I try to go on the example page via subdirectory, I get a white page https://ip_address/onlyofficeds/example/editor?fileName=new.docx

But my main problem is when I try to open an office document, I get the error “The document could not be saved. Please check connection settings or contact your administrator.”

I simply do not know where to go from here. I notice that the user ID of the file created by onlyoffice is 109, user name “ds” inside the container.

All my files have a userid of 1000, and they are accesed via NFS. I do not know if this is related.

Any help or hint would be greatly appreciated.


Not sure, but did your config include: ONLYOFFICE_JWT_SECRET
That was one of my problems.

Thanks for the reply and my bad if I haven’t reply back with my solution.
In my case, I’m using a docker instance for onlyoffice, and I have to set an environment variable

I can’t stop the server, but I also have in my
This could possible be True. I test different settings on my search for an answer and probably forgot to enable it back again. I will probably try it, but can’t for now