OnlyOffice Integration Problem With Blank Pages Due to Mixed SSL (Nginx Proxy)

I’m having a problem with OO integration.

From what I am gathering, it’s an issue with my Nginx proxy configuration. I have SF and OO working independently, both able to be accessed from their own domains.
Both are on their own servers. My Nginx proxy is also in its own server and handles SSL.

When I go to edit a file from SF using OO, I get a blank page. In console, I see that it’s caused from mixed SSL results.

Which I find strange as when I go to the url I entered in the seahub settings, it’s secured using SSL. Same with the confirm page that the OO server is running. All HTTPS, with a verified lock, and it auto redirects to HTTPS when I enter just http.

I’m hoping someone here has a similar set up using NGINX that can help me out in terms of the proper proxy set up

My current NGINX configuration file for the OO server:
My current NGINX configuration file for the SF server:
My current Seahub Configuration File:

For this threads proposes let’s say my Seafile is accessible from,
and OO is accessible from (

I installed OO using Docker compose (

It’s exposed at port 80, which is why my proxy can access it and make it HTTPS .