OnlyOffice with Apache not working

I’m trying to get OnlyOffice working on my Seafile installation but I can’t get it working.
I am running Seafile on Linux (OpenMediaVault) with Apache and this is working perfectly (https with LetsEncrypt certificate). Seafile and Apache installed normally, no docker.

Following these instructions I installed docker on my machine and then got OnlyOffice running in docker. shows the OnlyOffice welcome screen so basically OO is working as far as I can say ( is my server local IP).

I modified my Apache configuration to make OO available as a subfolder and this is my conf file:

<IfModule mod_ssl.c>

	NameVirtualHost _default_:443

	<VirtualHost _default_:443>

	    DocumentRoot /var/www/html

	    ErrorLog ${APACHE_LOG_DIR}/error.log
	    CustomLog ${APACHE_LOG_DIR}/access.log combined

	    Include /etc/letsencrypt/options-ssl-apache.conf
	    SSLCertificateFile /etc/letsencrypt/live/mydomain-0002/fullchain.pem
	    SSLCertificateKeyFile /etc/letsencrypt/live/mydomain-0002/privkey.pem

	    Alias /seafmedia /opt/seafile/seafile-server-latest/seahub/media

	    <Location /seafmedia>
	    ProxyPass !
			Require all granted

	    RewriteEngine On

	    # seafile httpserver
	    ProxyPass /seafhttp
	    ProxyPassReverse /seafhttp
	    RewriteRule ^/seafhttp - [QSA,L]

	    # seahub
	    SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
	    RequestHeader set X-Forwarded-Proto 'https' env=HTTPS
	    SetEnvIf Request_URI . proxy-fcgi-pathinfo=unescape

	    ProxyPass /
	    ProxyPassReverse /

	    # onlyofficeds
	    Define VPATH /onlyofficeds
	    Define DS_ADDRESS
	    <Location ${VPATH}>
	    Require all granted
	      SetEnvIf Host "^(.*)$" THE_HOST=$1
	      RequestHeader setifempty X-Forwarded-Proto https
	      RequestHeader setifempty X-Forwarded-Host %{THE_HOST}e
	      RequestHeader edit X-Forwarded-Host (.*) $1${VPATH}
	      ProxyAddHeaders Off
	      ProxyPass "http://${DS_ADDRESS}/"
	      ProxyPassReverse "http://${DS_ADDRESS}/"


Now when I open the link instead of the OO welcome screen I get an error message “Bad request (400)”

Anyone has an idea what the problem might be?


Three things:
1.) Why didn’t you post your Apache config? It is as important as the seafile.con
2.) Did you make the edits in the prescribed by the manual? You don’t mention them.
3.) Does OO run on the same machine as Seafile? If yes, why use and not localhost? By using the URL, you risk running into a blocked port 88.

@rdb: thanks to your reply, let me try to answer:

  1. actually seafile.conf is my Apache config
  2. no, not yet because first I need to make sure Onlyoffice is available via Only if this is working I can go on with the next step and integrate OO into seafile.
  3. yes, OO and Seafile are running on same machine. Seafile is installed ‘normally’ while OO is running in docker. I also tried to use instead of but same error message.