OpenStack Auth API v3 Support for Swift

Hello everyone,

I’m using Seafile Pro 7.0.9 with OpenStack Swift backend. OVH will shutdown Keystone Auth API v2. Will Seafile support Keystone Auth API v3 ?

[02/06/20 10:53:33] [Object store] Swift invalid auth_ver value v3 for fs_object_backend.
[02/06/20 10:53:33] ../common/obj-store.c(171): [Object store] Failed to load backend for fs.
[02/06/20 10:53:33] seaf-server.c(1576): Failed to create seafile session.

Kevin,

API v3 is already supported.

Ok Thanks.
Whic value should I set in seafile.conf ? auth_ver = v3 is not working

[Object store] Swift invalid auth_ver value v3 for fs_object_backend.

It is v3.0

Fine. It’w working now. Thank you.