Outdated docs (SQLite) and dependencies

i’m preparing my upgrade from 7.0.5 to 7.1.x. now that 7.1 is considered stable, the docs should no longer instruct you to install all python 2.7 as the default.

i was also wondering what the particular version number requirements are for the python3 packages. i’m always trying to stick to packages provided by the distribution repositories (ubuntu 18.04 in this case). there are some deb packages available for python libraries seafile server depends on:

  • python3-pylibmc (1.5.2)
  • python3-jinja2 (2.10)
  • python3-sqlalchemy (1.1.11)
  • django-simple-captcha (0.5.6)

can i use these packages instead of running pip3 install?

Welcome to the club :slight_smile: Yeah, will be good to know that. Specially the minor python version to use (3.6+?). Since stretch distro stops at 3.5, I need to update to buster, which will not really well accepted for olded distros rpi-users…

I’m struggling with python issues right now since yesterday I updated to buster, in oder to stick to python3 repositories provided by the distro.

Now I have to clean up all the mess… some binaries are in /usr/local/bin, others in /usr/bin and pip3 doesn’t work anymore.

After that, it will start the nightmare to recognize which thirdparty packages to install with pip3, which need to stick with 2.7, which could be provided by the distro…in order to compile the raspberry pi version. :worried: :worried: :worried:

3 Likes