Password incorrect if password length greater than 8 chars (seaf-cli)

Hi all,

i’m running seaf-cli on an headless arm device (seafile 6.0.6). unfortunately the password is always wrong if special characters (’@’ ‘!’ ‘?’ ‘_’ in this case) are used. I tried a demo library with 12345678 as password and it worked. i’m connecting from windows with putty. copy/pasting also didn’t work.
What else can i try?

Best regards

See EDIT below.

Maybe the keyboard layout on the windows device does not match with the layout on your target device? Assuming you are using linux, the command to change that should be

sudo dpkg-reconfigure keyboard-configuration

Unfortunately not. I’ve reset the keyboard layout:

  localectl set-locale LANG=de_DE.utf8
  localectl set-keymap de-latin1-nodeadkeys
  localectl --no-convert set-x11-keymap de pc105 nodeadkeys
  printf "de_DE.UTF-8 UTF-8" > /etc/locale.gen
  printf "en_US.UTF-8 UTF-8" >> /etc/locale.gen

Full error output:

Starting to download …
Enter password for the library:
Traceback (most recent call last):
File “/usr/bin/seaf-cli”, line 842, in
File “/usr/bin/seaf-cli”, line 838, in main
File “/usr/bin/seaf-cli”, line 578, in seaf_sync
email, random_key, enc_version, more_info)
File “/usr/lib/python2.7/site-packages/pysearpc/”, line 112, in newfunc
return fret(ret_str)
File “/usr/lib/python2.7/site-packages/pysearpc/”, line 25, in _fret_string
raise SearpcError(dicts[‘err_msg’])
pysearpc.common.SearpcError: Incorrect password

EDIT: I changed the password to a longer one with normal characters but i received the same error. It works now with 8 chars A-a,Z-z,0-9