Physical Size of Seafile does not reduce

Dear all

The seafile folder on my seafile server (Ubuntu, Seafile 5.1.4) uses 850GB of disk space.
The user’s libraries have an approximate size of 230GB (based on Lists “Users” in admin panel).

I did a GC twice last night, which reduces the disk space from 850GB to 830 GB.

Is there something else that I can do to reduce disk space and get back closer to this 230GB, that is being used?

You may have a long history?

In seafile.conf:

[history]
keep_days = days of history to keep

Hi Fabian

That made a lot of sense.
I had 60 (!) days history :wink:
Must come from 2 years ago when we started the seafile in the company and was <10 GB in size…

Probably 5 days history is more than enough considering that in 99% of the times this is being used to immediately fix the accidental deleting / overwriting of a specific file.

Just asking into the deep blue of the forum: how many days history do other people use?

Greetings, Chris

We’re also using 60 days in our setup. Some users still wish to have a bigger history… We’re fine with that setting.

Is it the default?
Do you know?

When I reduced the history to 5 days, the size of the seafile installtion did not get smaller.

Does anyone know I will I need to run the GC again for that to happen?

The default is unlimited, if i’m right. See here for the setting: http://manual.seafile.com/config/quota_and_size_options.html

After you changed something you need to restart seafile on the server. After this you may check in the webinterface if the setting has changed.

Then you should take a look at this page: http://manual.seafile.com/maintain/seafile_gc.html

Hi Marcus

I did the change to the settings and the reboot.

I will have to do a GC then, I guess.

Cheers :wink:

Yes :wink:

But first look into the webinterface if the settings are applied.

Regards,
Marcus

i have the same problem.

also did the same steps but I can not reduce the space used

Are you sure that:

  1. The setting is shown right in the webinterface?
  2. You did not run the GC in Dry-run Mode? NOT: ./seaf-gc.sh –dry-run
  3. There are libraries completely deleted and you have not removed them? If you are the admin you can look in the libraries page under the trash option. See:
    After this you should run agian with ./seaf-gc.sh -r
1 Like

thanks you!!!

filer.local.vafe.com.ar:/services 698G 590G 73G 90% /srv

filer.local.vafe.com.ar:/services 698G 503G 161G 76% /srv