Plasma logout canceled by Seafile applet


#9

It not a problem with KDE itself, it’s a problem with sth other because the same issue with Cinnamon.


#10

OK, so if it happens with several different DEs, then I’d say it’s more likely it’s the app and not all the DEs. It still looks to me that when the OS is sending the shutdown signal, Seafile app fails to catch it and ignores the shutdown. Then the OS shutdown halts due to an app running.


#11

That’s because Plasma doesn’t use root privileges for shutdown. If you write sudo halt, it will work.


#12

The issue happens to several different programs. It’s one of the major reasons I stopped using desktop environments and opted for Windows or Mac environments for GUI purposes. If I can recall correctly, it’s usually due to a program running as a daemon.


#13

Hi…is there any update on this? Seafile seems the only app that stop me from a quick and easy logout. I had Steam before having issues with that, but seems to have been fixed now.
https://store.steampowered.com/news/38412/
VLC had this issue long ago, but was fixed:
http://git.videolan.org/gitweb.cgi/vlc/vlc-1.1.git/?a=commit;h=c85aa861334a2693ee404301541a64d8941dd9eb

Transmission had that issue, and has been fixed now.
https://trac.transmissionbt.com/ticket/5206
An app called Cadence had this issue and has now been fixed.

My point being, this IS an issue WITH seafile, a bug that needs fixing. Please check what’s wrong to catch the shutdown signal with certain desktop environments, as it seems Seafile client really is ignoring them.

EDIT: The VLC submit is very clear on what might be the issue:

Qt4: accept close event on main interface (fix #4606)

If the event is ignored, the Qt4-X11 will reject the quit ICCM request.
This annoyingly caused VLC to inhibit logging out.


#14

I have the same problem and also would like to have it fixed. It is clearly a problem in the Seafile client.


#15

Same issue here.


#16

I’ll made a Github Issue, even if this isn’t very annoying, for myself. If they don’t fix it, I’ll try to fix it in my next holidays, hopefully they’ll accept my commit.


#17

Seems like there is already a fix, why it was never merged, is there anything to do @lins05?
Can you please give us an explanation about this, @daniel.pan?


#18

We wait now for over a month and still get no answer, even a explanation why you can implement the fix. We really need a statement on this @daniel.pan and @lins05.


#19

We don’t have time to look into the problem yet.


#20

But there is already a fix wit pull request as marked above. You just have to check if the CI doesn’t fail, you can merge it and deliver it with the new version. If the fix break things and doesn’t work, I will write a fix that works.


#21

If this patch isn’t just in my interest, you also have say something that they’ll fix it.


#22

@korry @timonoj @Martin @Simsala @wthess
I comitted the fix to latest version, please compile, test and send reports. Especially Cinnamon users, I’m KDE only.


#23

This is great news, thanks! Could you confirm which one will be the latest version? I’m on KDE Neon (so, ubuntu), and still didn’t see an updated version on my repository.


#24

No, for testing you have to compile it from source, but that shouldn’t be very complicated and amd64 ubuntu. If you use Debian you could also try the backports seafile packages from @schlarbm, they should have this fix in future versions.

Tipp: AUR users just need to modify the source and disable the checksums instead of compiling it with make.


#25

I did a quick test on Manjaro KDE and it worked.


#26

Hi @bionade24 , sorry, I am traveling these days, but will try your fix for sure and will post the results. I am on Kubuntu 18.04.


#27

Hi @bionade24, I have tested and it worked - thanks for the fix, I hope it will become official one day.


#28

Will now included in next release. Thread can be marked as solved. Thank you, seafile team!