Problem accessing libraries right-clicking in the seafile client


I’m running seafile-client 7.0.5 on archlinux, and whenever I right-click on a library and select “View on cloud”, it opens my default web browser but ends on this error message:

“Sorry, but the requested page could not be found.”

But I noticed that the url called is<library-id>/<library-name>/

whereas the correct url is<library-id>

I remember that a while ago I did not have this issue, but I can’t remember when it started.

Thanks in advance for help.

Hi Daddy33,

welcome to the Seafile Community Forum. Let’s try to fix your problem.

Please post the SERVICE_URL and the FILE_SERVER_ROOT from System Administration here:

Also: Have you checked your client’s proxy settings?


exactly the same settings (with different server name of course). No proxy set up in my client. Should there be one?

No, unless you use one.

I just checked the behavior of my Seafile client. This is the URL my Seafile client called for “Bibliothek-B”

As fas as I am concerned, your client calls the correct URL. Please verify!

So this is a server side issue? I’m using docker image for the server part.

Edit : I am wondering if this is because docker image uses seafile 6. Maybe I should upgrade to 7, but although I found detailed instructions, this is not completely straightforward.

Have you checked the client’s log files?

If you were using a Windows computer, I would recommend to reinstall the client. I am not sure that this piece of advice is relevant on a Linux computer.

Do you use a non standard port? Is this relevant for you: Seafile-7.0.6.msi client open website problem

I tried to reinstall the client, and came to the conclusion that this was not relevant in my situation…

That was it. I upgraded my seafile server to v7. And it’s now working!

Thanks all for your help!