Problem Upgrading

Using the Seafile Server 8.0.3 bundle, I’ve upgraded from 6.2 to 7.1. Seafile starts, but I get the following error when starting seahub.sh:

    Traceback (most recent call last):
      File "/seafile/seafile-server-8.0.3/seahub/thirdpart/bin/gunicorn", line 5, in <module>
        from gunicorn.app.wsgiapp import run
      File "/seafile/seafile-server-8.0.3/seahub/thirdpart/gunicorn/app/wsgiapp.py", line 9, in <module>
        from gunicorn.app.base import Application
      File "/seafile/seafile-server-8.0.3/seahub/thirdpart/gunicorn/app/base.py", line 11, in <module>
        from gunicorn import util
      File "/seafile/seafile-server-8.0.3/seahub/thirdpart/gunicorn/util.py", line 26, in <module>
        import pkg_resources
      File "/seafile/seafile-server-8.0.3/seahub/thirdpart/pkg_resources/__init__.py", line 81, in <module>
        raise RuntimeError("Python 3.5 or later is required")
    RuntimeError: Python 3.5 or later is required
    Error:Seahub failed to start.
    Please try to run "./seahub.sh start" again

I upgraded Python to version 3.6.9, and verified using “Python -V”
I have not yet tried to update the database with the upgrade/sql files

Thanks in advance for help

Hello!

Have you updated directly from 6.2 to 7.1? If yes, this would be the problem. You have to update to 7.0 first, as updgrade notes say:

Upgrade notes for 7.1.x

From 7.1.0 version, Seafile will depend on the Python 3 and is not compatible with Python 2.

Therefore you cannot upgrade directly from Seafile 6.x.x to 7.1.x.

If your current version of Seafile is not 7.0.x, you must first download the 7.0.x installation package and [ upgrade to 7.0.x ]

Sincerely Reitberger