Problem with download links [solved]

Hi all,

When i generate a download link with seafile client, my domain name appears two time in the link, as this : “https://mydomain/mydomain/f/b34a8eafa3/”.
Someone have an idea to solve it ?

Thank you for your help.

Is your service URL configured correctly?

Yes, URL are configured correctly in web interface and in configuration files, It’s why i don’t understand the problem.

Some redirect error in Nginx or Apache?

Yes, there is a redirect with apache, I have configure it as explained in Seafile server manual but i don’t use the standard https port, it can be the cause of the problem ?

Please post your apache config regarding Seafile and the part regarding URL From your Seafile config.

My apache config :

<IfModule mod_ssl.c>
    <VirtualHost *:8000>
            DocumentRoot /var/www
            Alias /media    /home/seafile/seafile-server-latest/seahub/media

            RewriteEngine On
            SSLEngine on

            SSLCertificateFile      /etc/letsencrypt/live/
            SSLCertificateKeyFile   /etc/letsencrypt/live/

            <Location /media>
                    Require all granted

            # seafile fileserver
            ProxyPass /seafhttp
            ProxyPassReverse /seafhttp
            RewriteRule ^/seafhttp - [QSA,L]

            # seahub
            SetEnvIf Request_URI . proxy-fcgi-pathinfo=unescape
            SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
            ProxyPass / fcgi://

In ccnet.conf :

In :

You cannot use Port 8000 as it’s beeing used by seahub itself !
Change your port to e.g. 8080.

Did you not read the manual carefully enough ? :wink:

I am wondering that it works at all. :smiley:

Seahub is configured to use port 8000 in loopback interface, not in output interface.
And I can assure it work.

It may still cause problems, please change and test. If it doesn’t help you can change back.

If i change port I need to reconfigure some firewalls, there is no another way ?

You can stay with 8000, but I don’t know of anybody who has used 8000 for outgoing traffic in combination with apache or nginx. You could try on a machine locally first before you change any firewall settings.

I have try it with a local VM with the same seafile configuration and with another port to apache and i have the same problem.

Thank you for your help, I have finally find the problem.
It is just a little misconfiguration in web interface.

Can you post what was the error so we can learn?

It’s just a typing error in SERVICE_URL, I have write “https:///” instead of “https://”.

1 Like