Public link cause 404 errors

Hi all,

I installed fresh Seafile server and all is working well (Ubuntu 16.04 + Apache 2.4 + SSL Lestsencrypt) except public link that cause http error 404 :sob:

Do you have any idea ? :

The Apache error log file :

file.xxx.xx:443 192.168.1.14 - - [11/Dec/2016:12:47:33 +0100] "GET /seafhttp/f/805f5fca44/ HTTP/1.1" 404 397 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0"

Apache configuration :
<VirtualHost *:443> ServerName file.xxx.xx DocumentRoot /var/www Alias /media /home/xxxx/Seafiles/seafile-server-latest/seahub/media RewriteEngine On <Location /media> Require all granted </Location> ProxyPass /seafhttp http://127.0.0.1:8082 ProxyPassReverse /seafhttp http://127.0.0.1:8082 RewriteRule ^/seafhttp - [QSA,L] SetEnvIf Request_URI . proxy-fcgi-pathinfo=unescape SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1 ProxyPass / fcgi://127.0.0.1:8000/ SSLCertificateFile /etc/letsencrypt/live/file.xxx.xx/fullchain.pem SSLCertificateKeyFile /etc/letsencrypt/live/file.xxx.xx/privkey.pem Include /etc/letsencrypt/options-ssl-apache.conf </VirtualHost>

In ccnet.conf :

SERVICE_URL = https://file.xxx.xx/seafhttp

In seahub_settings.py :

FILE_SERVER_ROOT = 'https://file.xxx.xx/seafhttp'

Solved :blush:

My mystake, with SERVICE_URL in ccnet.conf should be https://file.xxx.xx and not https://file.xxx.xx/seafhttp.