Pulling Latest Seafile Docker Image Breaks

Hello, I am having some issues with the seafile docker image. I just recently did a system update and reboot because its been several months since an update has been done. Now that I want to re-run the docker-compose file I am receiving the following error.

ERROR: failed to register layer: ApplyLayer exit status 1 stdout: stderr: unlinkat /bd_build/bin: invalid argument

I cleared out the cache and anything else that may have been lingering by entering
docker system prune -a
However, I am still receiving the same error. I also attempted to change the version from latest to 9.0.10, yet that did not resolve the issue. Not sure what could be the issue with this one since I am not building this image using a Docker File.

The following is the tree structure of my seafile directory within my Debian 10 server

|-- docker-compose.yaml
|-- mysql
|-- seafile-data

The following is the full error when pulling the seafile image

Pulling seafile (seafileltd/seafile-mc:9.0.10)...
9.0.10: Pulling from seafileltd/seafile-mc
345e3491a907: Pull complete
57671312ef6f: Pull complete
5e9250ddb7d0: Pull complete
e769497cf03b: Pull complete
9f18a1957c7a: Pull complete
1d8fa40f5695: Extracting [==================================================>]  55.29MB/55.29MB
466331959905: Download complete
bfdee83446db: Download complete
d7667f9da976: Download complete
da4d1c5cc341: Download complete
7f186ed022b2: Download complete
3fc3eeebb166: Download complete
f2411b59eb33: Download complete
3ceb140224fe: Download complete
ff63fd92f260: Download complete
be08112a3803: Download complete
d2d09430b592: Download complete
4c419f2c538a: Download complete
ERROR: failed to register layer: ApplyLayer exit status 1 stdout:  stderr: unlinkat /bd_build/bin: invalid argument

Let me know if you need to see my docker-compose file but I am lost with this one as to what would be the problem. Any advice would be greatly appreciated!

1 Like

Having this same issue, hangs on extracting 1d8fa40f5695 then docker just gives up. It seemed to be working early yesterday but stopped at some point last night while I was setting it up.

Were you able to find a solution for this or if you know anyone else having this issue on github? I couldn’t find any

I attempted different version types including 7.1.4, which is 3 years old and still get the same error.

With more testing I found that I did not get the same issue when I ran it within a Proxmox VM using docker instead of Proxmox LXC (original set up), however, I still get an issue with the docker image.

Below is the latest docker image and I am getting a 502 error. It’s getting late so I’ll have to take a look at a later time but below are my results.

[$] docker ps                                                                                                                                                                     [3:44:32]
CONTAINER ID   IMAGE                          COMMAND                  CREATED         STATUS         PORTS                                   NAMES
4fc35f8d9efc   seafileltd/seafile-mc:latest   "/sbin/my_init -- /s…"   2 minutes ago   Up 2 minutes>80/tcp, :::9880->80/tcp   seafile
e159b0129cbb   mariadb:10.5                   "docker-entrypoint.s…"   4 minutes ago   Up 2 minutes   3306/tcp                                seafile-mysql
a7ca919bce19   memcached:1.5.6                "memcached -m 256"       4 minutes ago   Up 2 minutes   11211/tcp                               seafile-memcached
[$] curl                                                                                                                                                           [3:44:35]
<head><title>502 Bad Gateway</title></head>
<center><h1>502 Bad Gateway</h1></center>
<hr><center>nginx/1.18.0 (Ubuntu)</center>

Maybe it is something to do with proxmox LXC since thats how I’m trying to run it too. Saw something saying that changing the storage driver might help so I’m going to try that later.