[Raspberry Server] Error: Seahub failed to start - Troubleshooting

Hey guys,
a week or so ago, i set up a seafile server on my raspberry pi (using raspian jessie as os). I followed the instructions on this liknk and used the latest raspbian release (6.0.8). It worked perfectly fine for some time until i realized my machines cant connect to the server anymore.

When I looked into the pi i realized there is an error starting seahub:

$ ./seafile.sh start && ./seahub.sh start

[04/08/17 11:56:53] ../common/session.c(132): using config file /home/pi/haiwen/conf/ccnet.conf
Starting seafile server, please wait ...
Seafile server started

Done.

LC_ALL is not set in ENV, set to en_US.UTF-8
./seahub.sh: line 207: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
Starting seahub at port 8000 ...
Error:Seahub failed to start.
Please try to run "./seahub.sh start" again

When looking into the logs in seafile-server-latest/logs/ i can only see the same error message in seafile.init.log and nothing else. SO I don’t really know where the problem is. I looked around in the server manual and tried deleting /tmp/seahub_cache, which didn’t help. I also saw the tip on checkin user rights for seahub.pid, seahub_django_request.log and seahub.log, but I don’t know what user needs which permissions. Also I didn’t change any permissions there so it would be weird to do that on it’s own.

Any Idea on how to get the server working again?

Greetings

Did you mean seahub.init.log? Because the error message says that seahub failed to start - not seafile.
Can you post your log files somewhere? Pastebin or so?

Yes, i meant seahub.init.log, sorry. I can upload the logs when I’m back home.

Ah, and please post your configs. (e.g. seahub_settings.py) I guess you don’t use nginx or apache as frontend?

Nope, just the basic sqlite deployment for the Raspberry. I’ll upload everything asap

New users can only share 2 links. So i posted links to all of my logs and configs to reddit.

You can find it in THIS THREAD

In my seahub_settings.py is also the following entry:

HTTP_SERVER_ROOT = 'http://yourdomain.com:8000/seafhttp'

Maybe it’s worth a try…

//edit: I just saw, that if you don’t use Apache or Nginx you don’t need that entry… Hm… Maybe anyone else has an idea?

I added the line, but it still won’t start :confused:

I guess you already restarted your server? Sometimes the scripts fail to start when a process is still running (see “When scripts fail” under https://manual.seafile.com/deploy/using_sqlite.html).

Yep. Restarting and clearing the cache does nothing. it still fails.