Recover old data from seafile v3 - fsck not working, client refuses because too old - all my private documents lost


#1

Hi folks.

Something rather bad happened, such that I cannot get to my data anymore. I had a server version 3 on Ubuntu server 10.04 running plus a linux client on Ubuntu 16.04. Seafile worked flawlessly but at some point my local hard disk on client side broke and I had to reinstall client system. Because on the Seafile webpage there was no old client version available, I went with the latest one.

Well, the latest client version refused to work with my old server version. Hence, I went ahead and upgraded the server. However, what happened now is that the upgraded server refused to start because GLIBC version was too old (well I was running Ubuntu 10.04 after all). Hence my next step was to book a new server with latest ubuntu and copy the seafile installation over there. Finally I was able to make the latest seafile server running (v 6.2.5). However, now my client refuses to sync the library because it is too old.

Next I tried to export the library with seaf-fsck.sh, but this does fail to export with error message:
[05/31/19 22:50:23] Failed to inflate.
[05/31/19 22:50:23] …/…/common/fs-mgr.c(2868): Failed to decompress fs object e1ba10be579375de3cae9c7b09d9d82929aa4c85.

I guess it cannot export because it is an encrypted library.

So, here I am now, having data in the seafile repo not reachable or exportable in anyway. Client refuses to sync it because it is too old. Fsck tool refuses to unpack it.

Is there anything I can do to still restore my data? It were pretty much all my private documents incl. stuff required for tax reports and what not - well my whole private collection of documents. And well encrypted to be on safe side.

Another option I see could be to somehow downgrade the seafile server now from v6 down to v4 and try to find somewhere old client version which would be able to connect to this server. I am not sure how to downgrade though.

Any help very appreciated!

p.s. willing to pay for support if this means I can get my data back


#2

ok, problem has been partly resolved. I was able to run old seafile server version and get access to my data over the web interface. From there I downloaded most of the important data. It would be nicer to get it with a client, but this is better then loosing data.

I think the problem can be closed.


#3

I build a 3.1.12 client on a fully patched Ubuntu 18.04. You can download it here: https://seafile.zfn.uni-bremen.de/f/29618fb691334bf28aad/ (alternative download)

sudo tar xvfz seafile-gui-3.1.2-ubuntu18.04.tar.gz -C /
sudo apt install libqt4-dev libjansson4
/usr/local/bin/seafile-applet

Note: Depending on your installation you might need to install other dependencies!

HTH!