Run Docker Seafile 7 on the port 8000 instead of 80

Hi,

Since version 3, I have always been using Seafile Server with the web interface configured to listen on the port 8000. I kept the ports 80/443 for my own web app. They were both running on the same dedicated server.

The Docker version of Seafile 7 seems to be using the ports 80/443 by default. I have made the following changes to the sample docker-compose.yml :

seafile:
image: seafileltd/seafile-mc:latest
container_name: seafile
ports:
- “8000:80”
volumes:
- /opt/seafile-data:/shared

At first Seahub seems to be working. But it fails uploading/downloading files. It seems to be coming from the port change I did.

I’m using NGINX next to Docker Seafile. Is there a way to solve this only using docker-compose (I guess not) or I will have to make some changes to my NGINX conf ?

I have seen that someone documented how to achieve this with Apache here but I haven’t found anything for NGINX.

are your SERVICE_URL and FILE_SERVER_ROOT values set correctly in the admin settings?

Ok, I don’t see these values in the sample docker-compose.yml here neither in the Docker documentation

So I guess I have no other choice than access the container directly to edit the conf files ?

you should be able to edit them in the web UI unter “system administration”
https://<hostname>/sys/web-settings/

Ok, so my settings were :

SERVICE_URL : http://mydomain:8000
FILE_SERVER_ROOT: http://mydomain/seafhttp

I have changed FILE_SERVER_ROOT to http://mydomain:8000/seafhttp

And now it works ! Thanks !

I will try to setup SSL now…